Permalink
Browse files

bump version and make dependencies on couchrest and restclient explic…

…it so that we can specify a version
  • Loading branch information...
1 parent 760e778 commit 299800a4a09776de1cae667c2b5264e7828bbc0b @jweiss committed Sep 30, 2010
Showing with 12 additions and 4 deletions.
  1. +3 −1 Rakefile
  2. +1 −1 VERSION
  3. +8 −2 rocking_chair.gemspec
View
@@ -20,7 +20,9 @@ begin
s.authors = ["Jonathan Weiss"]
s.files = FileList["[A-Z]*.*", "{lib}/**/*"]
s.add_dependency('simply_stored', '>= 0.1.12')
+ s.add_dependency('rest-client', '>= 1.6.1')
+ s.add_dependency('couchrest', '>= 1.0.1')
end
rescue LoadError
puts "Jeweler not available. Install it with: sudo gem install technicalpickles-jeweler -s http://gems.github.com"
-end
+end
View
@@ -1 +1 @@
-0.2.1
+0.2.2
View
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = %q{rocking_chair}
- s.version = "0.2.1"
+ s.version = "0.2.2"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Jonathan Weiss"]
- s.date = %q{2010-09-14}
+ s.date = %q{2010-09-30}
s.description = %q{In-memory CouchDB for Couchrest and SimplyStored. Works for database and document API, by_attribute views, and for SimplyStored generated views}
s.email = %q{jw@innerewut.de}
s.extra_rdoc_files = [
@@ -50,11 +50,17 @@ Gem::Specification.new do |s|
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<simply_stored>, [">= 0.1.12"])
+ s.add_runtime_dependency(%q<rest-client>, [">= 1.6.1"])
+ s.add_runtime_dependency(%q<couchrest>, [">= 1.0.1"])
else
s.add_dependency(%q<simply_stored>, [">= 0.1.12"])
+ s.add_dependency(%q<rest-client>, [">= 1.6.1"])
+ s.add_dependency(%q<couchrest>, [">= 1.0.1"])
end
else
s.add_dependency(%q<simply_stored>, [">= 0.1.12"])
+ s.add_dependency(%q<rest-client>, [">= 1.6.1"])
+ s.add_dependency(%q<couchrest>, [">= 1.0.1"])
end
end

0 comments on commit 299800a

Please sign in to comment.