Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 167 lines (108 sloc) 5.179 kb
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
1 <!-- Marked Style: GitHub -->
2
3 ## requirejs-rails changelog
4
6023114 @carsomyr Fix a bad regression and yank 0.9.7
carsomyr authored
5 ### v0.9.8
6
7 - Fix a bad regression and yank v0.9.7.
8
d2cc2ca @carsomyr Upgrade the gem to 0.9.7
carsomyr authored
9 ### v0.9.7
10
11 - Fix a corner case where modules could appear in the build config's `paths`.
12 - Fix regressions introduced in v0.9.6.
13 - Allow protocol relative urls for CDNs in the build config's `paths` (credit @remybach).
14
7d6cc88 @carsomyr Update the gem version to `0.9.6`
carsomyr authored
15 ### v0.9.6
16
17 - Update `require.js` and `r.js` to `2.1.17`, and `almond.js` to `0.3.1`.
18 - Improve handling of Bower packages.
19 - Make a small fix for Sprockets 3 support.
20
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
21 ### v0.9.5
22
23 - Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`.
24 - Remove `data-main` attribute generation from `requirejs_include_tag` and replicate its functionality with an explicit
25 `require` call. This paves the way for proper almond support.
26 - Instead of disabling JS compression everywhere, only do so when staging `r.js` input files. This enables `require.js`
27 itself to be compiled (or not) by the asset pipeline, like any other asset.
28 - Add support for `bower.json` modules.
29
30 ### v0.9.4
5cc76c6 @wuservices Update the gem version to `0.9.4`, RequireJS to `2.1.14`
wuservices authored
31
d894eb3 @carsomyr Update the changelog and readme
carsomyr authored
32 - Restore compression of non-module JS assets if specified, including `require.js` itself.
fa601de @carsomyr Update the changelog
carsomyr authored
33 - Update `require.js` to `2.1.14`.
5cc76c6 @wuservices Update the gem version to `0.9.4`, RequireJS to `2.1.14`
wuservices authored
34
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
35 ### v0.9.3
d14e8df @carsomyr Update the gem version to `0.9.3`, RequireJS to `2.1.11`, and almond …
carsomyr authored
36
fa601de @carsomyr Update the changelog
carsomyr authored
37 - Add detection and proper handling of Bower-based modules.
d14e8df @carsomyr Update the gem version to `0.9.3`, RequireJS to `2.1.11`, and almond …
carsomyr authored
38 - Update `require.js` to `2.1.11` and `almond.js` to `0.2.9`.
39
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
40 ### v0.9.2
a5b71ae @carsomyr Update the gem version to `0.9.2`
carsomyr authored
41
42 - Update `require.js` to `2.1.10` and `almond.js` to `0.2.5`.
43 - Rails 4 support.
44
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
45 ### v0.9.1
813731f @gurdotan Update to require.js 2.1.2
gurdotan authored
46
571101a @jwhitley Fix almond.js version in changelog
authored
47 - Updated to to require.js \ r.js 2.1.2, and almond 0.2.3
813731f @gurdotan Update to require.js 2.1.2
gurdotan authored
48
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
49 ### v0.9.0
1633e0a @jwhitley Prepare for v0.9.0 release
authored
50
51 - **BREAKING CHANGE**: Upgrade RequireJS and r.js to v2.0.0
52 - order.js was removed. See the new [RequireJS 2.0 shim config](https://github.com/jrburke/requirejs/wiki/Upgrading-to-RequireJS-2.0#wiki-shim).
53 - Build support for `empty:` is now handled by r.js 2.0 natively.
54
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
55 ### v0.8.2
9998644 @jwhitley Prepare for v0.8.2 release
authored
56
57 - Fix for `requirejs_include_tag` error when `config/requirejs.yml` has no
58 `paths` key. Thanks to @JustinLove for the issue and failing test!
c834052 @jwhitley Try adding a MultiMarkdown header
authored
59
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
60 ### v0.8.0
5f1224e @jwhitley Documentation and changelog updates for this work
authored
61
62 - Build will now substitute `empty:` for the right-hand side of
63 `config/requirejs.yml` paths entries that are URLs.
64 - Documented how to configure assets hosted on a CDN.
65
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
66 ### v0.7.3
d6668c4 @jwhitley Prepare for v0.7.3 release
authored
67
68 - Upgrade RequireJS and r.js to v1.0.8
69
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
70 ### v0.7.2
f1beaaa @jwhitley Prepare for 0.7.2 release
authored
71
72 - Add require.js to config.assets.precompile in all environments. Closes #45.
73 This change allows builds to work in Rails environments other than
74 'production', e.g. 'staging'. Thanks to @hollow for the fix.
75
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
76 ### v0.7.1
45a3d04 @jwhitley Prepare for 0.7.1 release
authored
77
78 - Liberalize asset path filtering. `0.7.0` added filtering on the logical
79 asset path which was too aggressive in that only `.js` files were allowed in
80 builds. The RequireJS config variable `logical_asset_filter` has been
81 added, which allows `.js`, `.html`, `.txt` files by default and is user
82 configurable.
83
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
84 ### v0.7.0
2af6359 @jwhitley Update documentation for Almond support.
authored
85
86 - Support for [almond](https://github.com/jrburke/almond) via
87 `config.requirejs.loader = :almond` in application.rb.
8f00855 @jwhitley Prepare for v0.7.0 release.
authored
88 - Builds with `config.assets.initialize_on_precompile = false` now work.
89 This supports building on Heroku, builds with Devise, etc. all of
90 which require that setting.
91 - We should now play much better with existing Rails Engines that
92 leverage the asset pipeline for their needs. Thanks to @hollow for the
93 patch.
2af6359 @jwhitley Update documentation for Almond support.
authored
94
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
95 ### v0.6.1
c6a2dfa @jwhitley Fix requirejs_include_tag regression in production
authored
96
97 - Fix regression in production env when `paths` specified in requirejs.yml.
98
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
99 ### v0.6.0
7e620d9 @jwhitley Update changelog.
authored
100
c6a2dfa @jwhitley Fix requirejs_include_tag regression in production
authored
101 **NOTE:** Upgrade to 0.6.1! This was yanked due to a regression.
102
06af626 @jwhitley Prepare for 0.6.0 release.
authored
103 - We now generate a paths config to hit digested assets when needed (in
104 `production` or when `config.assets.digest` is true). Fixes #20.
105 - Support for generating additional data attributes on the require.js script
106 tag via `requirejs_include_tag`. See [README](README.md) for details. Closes
107 pull request #32; thanks to @hollow for the submission!
7e620d9 @jwhitley Update changelog.
authored
108
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
109 ### v0.5.6
0203daa @jwhitley Prepare for 0.5.6 release.
authored
110
111 - Upgrade to RequireJS and r.js 1.0.7
112
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
113 ### v0.5.5
e270d76 @jwhitley Prepare for 0.5.5 release.
authored
114
115 - Support for Rails 3.2.x. Rails 3.1.x is also supported by this release.
116
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
117 ### v0.5.4
142c5a6 @jwhitley Prepare for 0.5.4 release.
authored
118
119 - Upgrade to RequireJS and r.js 1.0.5
120 - Pull request #31, closes #30. Thanks @karelim!
121
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
122 ### v0.5.3
1e90e35 @jwhitley Prepare for v0.5.3 release.
authored
123
124 - Upgrade to RequireJS and r.js 1.0.4
125 - Pulled #22, fix for asset compliation failure with no config/requirejs.yml.
126 Thanks @arehberg!
127
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
128 ### v0.5.2
04c287a @jwhitley Update changelog
authored
129
130 - Upgrade to RequireJS and r.js 1.0.3
131
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
132 ### v0.5.1
614abfe @jwhitley Update Changelog for v0.5.1.
authored
133
134 - This is a quick turn to fix an issue that could trigger an Anonymous mismatched define() error from require.js and/or r.js.
135
136 The preferred way to use the helper tag is now with an argument, like
137 so:
138
139 ```erb
140 <%= requirejs_include_tag "application" %>
141 ```
142
143 This usage ensures that the above helper will correctly generate a
144 data-main attribute for the script tag. The requirejs_include_tag
145 helper still works without an argument, and won't generate data-main
146 in that case.
147
148 Thanks to Andrew de Andrade for the catch.
149
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
150 ### v0.5.0
d2035f1 @jwhitley Docs and version updates in preparation for 0.5.0 release.
authored
151
152 - Precompilation via `rake assets:precompile` is now implemented.
153 - gem configuration via application.js is deprecated.
154 - Application-specific require.js configuration lives in `config/requirejs.yml`.
155 - See [README](README.md) for updated usage details.
156
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
157 ### v0.0.2
7080367 @jwhitley Update Changelog for v0.0.2
authored
158
159 - Fixed stupid problems with Rails::Engine instantiation.
160 - Test improvements
161 - Upgrade to RequireJS 1.0.2
162
f8943fb @carsomyr Update `require.js` and `r.js` to `2.1.15`, and `almond.js` to `0.3.0`
carsomyr authored
163 ### v0.0.1
62460be @jwhitley Prep for v0.0.1 release.
authored
164
165 - Birthday!
166 - This gem makes `require.js` and the `order.js` plugin available to the Rails 3 Asset Pipeline.
Something went wrong with that request. Please try again.