Skip to content
  • 1 commit
  • 1 file changed
  • 0 commit comments
  • 1 contributor
Commits on May 02, 2012
@jwood Heroku seems to have difficulty with dependencies set to a specific v…
…ersion (using =). Revert back to ~> to specify the version.
adb2a3b
Showing with 18 additions and 18 deletions.
  1. +18 −18 tenacity.gemspec
View
36 tenacity.gemspec
@@ -20,34 +20,34 @@ Gem::Specification.new do |s|
s.add_development_dependency "bundler", ">= 1.0.0"
s.add_development_dependency "rake", ">= 0.8.7"
- s.add_development_dependency "rcov", "0.9.9"
- s.add_development_dependency "shoulda", "2.11.3"
- s.add_development_dependency "mocha", "0.9.10"
- s.add_development_dependency "yard", "0.6.4"
+ s.add_development_dependency "rcov", "~> 0.9.9"
+ s.add_development_dependency "shoulda", "~> 2.11.3"
+ s.add_development_dependency "mocha", "~> 0.9.10"
+ s.add_development_dependency "yard", "~> 0.6.4"
# Relational DBs
- s.add_development_dependency "sqlite3-ruby", "1.3.1"
- s.add_development_dependency "activerecord", "3.0.7"
- s.add_development_dependency "datamapper", "1.0.2"
- s.add_development_dependency "dm-sqlite-adapter", "1.0.2"
- s.add_development_dependency "sequel", "3.19.0"
+ s.add_development_dependency "sqlite3-ruby", "~> 1.3.1"
+ s.add_development_dependency "activerecord", "~> 3.0.7"
+ s.add_development_dependency "datamapper", "~> 1.0.2"
+ s.add_development_dependency "dm-sqlite-adapter", "~> 1.0.2"
+ s.add_development_dependency "sequel", "~> 3.19.0"
# MongoDB
- s.add_development_dependency "mongo_mapper", "0.9.0"
- s.add_development_dependency "mongo", "1.6.2"
- s.add_development_dependency "bson_ext", "1.6.2"
- s.add_development_dependency "mongoid", "2.0.0"
+ s.add_development_dependency "mongo_mapper", "~> 0.9.0"
+ s.add_development_dependency "mongo", "~> 1.6.2"
+ s.add_development_dependency "bson_ext", "~> 1.6.2"
+ s.add_development_dependency "mongoid", "~> 2.0.0"
# CouchDB
- s.add_development_dependency "couchrest", "1.0.2"
- s.add_development_dependency "couchrest_model", "1.0.0"
+ s.add_development_dependency "couchrest", "~> 1.0.2"
+ s.add_development_dependency "couchrest_model", "~> 1.0.0"
# Riak
- s.add_development_dependency "ripple", "0.9.2"
+ s.add_development_dependency "ripple", "~> 0.9.2"
# Multiple
- s.add_development_dependency "toystore", "0.8.0"
- s.add_development_dependency "adapter-mongo", "0.5.4"
+ s.add_development_dependency "toystore", "~> 0.8.0"
+ s.add_development_dependency "adapter-mongo", "~> 0.5.4"
s.files = `git ls-files`.split("\n")
s.executables = `git ls-files`.split("\n").map{|f| f =~ /^bin\/(.*)/ ? $1 : nil}.compact

No commit comments for this range

Something went wrong with that request. Please try again.