Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Add rspec-rails gem and install #1

Closed
wants to merge 1 commit into from

2 participants

@andyw8
Collaborator

No description provided.

@k0954342 k0954342 closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Apr 8, 2013
  1. @andyw8
This page is out of date. Refresh to see the latest.
Showing with 61 additions and 0 deletions.
  1. +1 −0  .rspec
  2. +4 −0 Gemfile
  3. +18 −0 Gemfile.lock
  4. +38 −0 spec/spec_helper.rb
View
1  .rspec
@@ -0,0 +1 @@
+--color
View
4 Gemfile
@@ -29,5 +29,9 @@ group :assets do
gem 'uglifier', '>= 1.0.3'
end
+group :development do
+ gem 'rspec-rails'
+end
+
#gem 'bullet', :group => 'development'
#gem 'quiet_assets', :group => 'development'
View
18 Gemfile.lock
@@ -31,6 +31,7 @@ GEM
annotate (2.5.0)
rake
arel (3.0.2)
+ bcrypt-ruby (3.0.1)
bcrypt-ruby (3.0.1-x86-mingw32)
builder (3.0.4)
cancan (1.6.9)
@@ -48,7 +49,9 @@ GEM
orm_adapter (~> 0.1)
railties (~> 3.1)
warden (~> 1.2.1)
+ diff-lcs (1.2.2)
erubis (2.7.0)
+ eventmachine (1.0.3)
eventmachine (1.0.3-x86-mingw32)
execjs (1.4.0)
multi_json (~> 1.0)
@@ -73,8 +76,10 @@ GEM
rails
mime-types (1.22)
multi_json (1.7.2)
+ mysql2 (0.3.11)
mysql2 (0.3.11-x86-mingw32)
orm_adapter (0.4.0)
+ pg (0.15.0)
pg (0.15.0-x86-mingw32)
polyglot (0.3.3)
rack (1.4.5)
@@ -104,6 +109,17 @@ GEM
rake (10.0.4)
rdoc (3.12.2)
json (~> 1.4)
+ rspec-core (2.13.1)
+ rspec-expectations (2.13.0)
+ diff-lcs (>= 1.1.3, < 2.0)
+ rspec-mocks (2.13.0)
+ rspec-rails (2.13.0)
+ actionpack (>= 3.0)
+ activesupport (>= 3.0)
+ railties (>= 3.0)
+ rspec-core (~> 2.13.0)
+ rspec-expectations (~> 2.13.0)
+ rspec-mocks (~> 2.13.0)
sass (3.2.7)
sass-rails (3.2.6)
railties (~> 3.2.0)
@@ -134,6 +150,7 @@ GEM
wkhtmltopdf-heroku (1.0.0)
PLATFORMS
+ ruby
x86-mingw32
DEPENDENCIES
@@ -150,6 +167,7 @@ DEPENDENCIES
mysql2
pg
rails (= 3.2.11)
+ rspec-rails
sass-rails (~> 3.2.3)
thin
uglifier (>= 1.0.3)
View
38 spec/spec_helper.rb
@@ -0,0 +1,38 @@
+# This file is copied to spec/ when you run 'rails generate rspec:install'
+ENV["RAILS_ENV"] ||= 'test'
+require File.expand_path("../../config/environment", __FILE__)
+require 'rspec/rails'
+require 'rspec/autorun'
+
+# Requires supporting ruby files with custom matchers and macros, etc,
+# in spec/support/ and its subdirectories.
+Dir[Rails.root.join("spec/support/**/*.rb")].each {|f| require f}
+
+RSpec.configure do |config|
+ # ## Mock Framework
+ #
+ # If you prefer to use mocha, flexmock or RR, uncomment the appropriate line:
+ #
+ # config.mock_with :mocha
+ # config.mock_with :flexmock
+ # config.mock_with :rr
+
+ # Remove this line if you're not using ActiveRecord or ActiveRecord fixtures
+ config.fixture_path = "#{::Rails.root}/spec/fixtures"
+
+ # If you're not using ActiveRecord, or you'd prefer not to run each of your
+ # examples within a transaction, remove the following line or assign false
+ # instead of true.
+ config.use_transactional_fixtures = true
+
+ # If true, the base class of anonymous controllers will be inferred
+ # automatically. This will be the default behavior in future versions of
+ # rspec-rails.
+ config.infer_base_class_for_anonymous_controllers = false
+
+ # Run specs in random order to surface order dependencies. If you find an
+ # order dependency and want to debug it, you can fix the order by providing
+ # the seed, which is printed after each run.
+ # --seed 1234
+ config.order = "random"
+end
Something went wrong with that request. Please try again.