Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Gnome 3.4 #21

Open
leezu opened this Issue · 10 comments

10 participants

@leezu

Hey there,

it would be great, if sb could enable (or build, dont know if there were API changes or so) gnome 3.4 support :-)

thanks for the great work so far @ all

@leezu

ok, actually its version gnome-unstable/gnome-shell 3.3.91-0 ;-)

@Slix

I tried simply adding "3.4" as a valid version to the metadata file, but that didn't work. (The extensions website reports an error.)

@lxp
lxp commented

galpec mentioned on extensions.gnome.org that he has modified the extension for Gnome 3.4.
https://extensions.gnome.org/extension/214/pidgin-conversation-integration/

@skoruppa

One more waiting for this update ;)

@atomfrede

Not sure but isn't it enough to add 3.4.0 to the metadata.json file or requires 3.4 something more?

@bugflux

Just "3.4" doesn't work for me as well...
There's some problem about metadata.locale not being evaluated as an UTF-8 string. Hardcoding the "/usr/share/locale" seems to solve the issue...

@pentie

Try this, worked for me.

diff --git a/extension.js b/extension.js
index 4e3267f..12bebc0 100644
--- a/extension.js
+++ b/extension.js
@@ -695,6 +695,6 @@ PidginClient.prototype = {
 }

 function init(metadata) {
-    imports.gettext.bindtextdomain('gnome-shell-extensions', metadata.localedir);
+    imports.gettext.bindtextdomain('gnome-shell-extensions', imports.misc.config.LOCALEDIR);
     return new PidginClient();
 }
diff --git a/metadata.json b/metadata.json
index 0fa128b..ddcb81e 100644
--- a/metadata.json
+++ b/metadata.json
@@ -2,7 +2,7 @@
  "uuid": "pidgin-conversation-integration@kagesenshi.org",
  "name": "Pidgin Conversation Integration",
  "description": "Display Pidgin chats as notifications in the Shell message tray.",
- "shell-version": [ "3.1.91", "3.1.92", "3.2" ],
+ "shell-version": [ "3.1.91", "3.1.92", "3.2", "3.4" ],
  "localedir": "/usr/share/locale",
  "url": "https://github.com/kagesenshi/gnome-shell-extensions-pidgin"
 }
@Slix Slix referenced this issue from a commit
pentie Update to work with Gnome Shell 3.4
Patch provided by @pentie in kagesenshi#21.
739ea42
@Slix Slix referenced this issue from a commit
pentie Update to work with Gnome Shell 3.4
Patch provided by @pentie in kagesenshi#21.
a16d4c5
@ambasta

The suggested patch breaks the extension on gnome-shell 3.2 with:
Failed to evaluate init function. Error invoking bindtext domain at argument 2 Object is not a string, cannot convert to UTF-8

@ildar

plz upgrade to 3.6

@rajeshksv

plz upgrade to 3.6

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.