Skip to content
master
Switch branches/tags
Go to file
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
 
 
 
 
app
 
 
 
 
 
 
 
 
lib
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

ember-bootstrap

CI BrowserStack Status Ember Observer Score npm version

An ember-cli addon for using Bootstrap 3 or 4 in Ember applications.

The addon includes the Bootstrap CSS (or Sass, Less) in your project (can be disabled). On top of that, it provides a set of native Ember components (no use of Bootstrap JavaScript!).

See www.ember-bootstrap.com for full documentation.

Installation

In your application's directory:

ember install ember-bootstrap

This will install Bootstrap 4 and will use the currently installed preprocessor or none if one is not installed. To switch Bootstrap version or preprocessor, see the setup documentation.

Compatibility

Ember Bootstrap works and is fully tested with

  • Ember.js 3.16+ (including all optional features)
  • Ember CLI 3.15+
  • Bootstrap 3 and 4
  • all modern evergreen browsers (Chrome, Firefox, Safari, Edge) and IE 11 (the latter requires the use of the Babel polyfill).
  • FastBoot 1.0+
  • Embroider: we strive (and test) for maximum compatibility with Embroider, including the most aggressive setting (staticComponents) for tree shaking and code splitting. However as Embroider itself is still considered beta software, we won't be able to guarantee that for the time being.

This project follows Semantic Versioning.

Updates

See CHANGELOG for the list of all changes.

If you want to keep up to date with ember-bootstrap, you may want to follow me on Twitter.

Author and collaborators

Contributing

See the Contributing guide for details.

Credits

Cross-browser testing provided by:

BrowserStack

Copyright and license

Code and documentation copyright 2020 kaliber5 and contributors. Code released under the MIT license.