New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support for Middleman v4? #93

Closed
tomsabin opened this Issue Aug 6, 2015 · 6 comments

Comments

Projects
None yet
7 participants
@tomsabin

tomsabin commented Aug 6, 2015

"Remove old module-style extension support" is on the list of the v4 upgrade path, which I believe has caused the following error when trying to rebuild a simple Middleman app:

$ middleman build
.../gems/middleman-core-4.0.0.beta.2/lib/middleman-core/extensions.rb:96:in `load':
Tried to activate old-style extension: deploy. They are no longer supported. (RuntimeError)
# config.rb
activate :deploy do |deploy|
  deploy.method = :git
end

Could anyone shed any light if there are any plans for v4 compatibility for middleman-deploy?

@rriemann

This comment has been minimized.

rriemann commented Aug 16, 2015

There is a related pull-request #87 .

locks added a commit to ember-learn/middleman-deploy that referenced this issue Apr 22, 2016

@fwolfst

This comment has been minimized.

fwolfst commented Apr 30, 2016

Do I understand correctly that we'll have to wait for 2.0 ? Currently I get the same error message as in the original post.

suzuryo added a commit to IWDD/iwdd.net-middleman that referenced this issue Jun 18, 2016

@danbartlett

This comment has been minimized.

danbartlett commented Aug 5, 2016

Using gem 'middleman-deploy', '~> 2.0.0.pre.alpha' as suggested in the referenced commit by @suzuryo worked for me

@kahboom

This comment has been minimized.

kahboom commented Mar 23, 2017

Thanks @danbartlett; that workaround fixed it for me. 👍

@satanin

This comment has been minimized.

satanin commented Jul 19, 2017

HI @karlfreeman any change this (#87) will be merged into a non alpha version?
Thx

@vaskaloidis

This comment has been minimized.

vaskaloidis commented Oct 17, 2018

Is anyone going to update the README ever? New Middleman users will have not be able to get it running without diagnosing two bugs and their solutions in two seperate Repo Issues: 1) The only working version requires people to use 2.0 pre-alpha despite the README saying 1.0, and 2) to use deploy_method in the config, which has replaced method.. I would contribute, but the fix is sitting in an open pull-request for this!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment