New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

How to install version 0.10 #686

Closed
janbaer opened this Issue Aug 8, 2013 · 7 comments

Comments

Projects
None yet
4 participants
@janbaer

janbaer commented Aug 8, 2013

Hello,

I've tried to install the new version of karma, but I got this errors:

npm ERR! peerinvalid The package karma does not satisfy its siblings' peerDependencies requirements!
npm ERR! peerinvalid Peer karma-chrome-launcher@0.0.2 wants karma@~0.9.3
npm ERR! peerinvalid Peer karma-coffee-preprocessor@0.0.2 wants karma@~0.9
npm ERR! peerinvalid Peer karma-firefox-launcher@0.0.3 wants karma@~0.9
npm ERR! peerinvalid Peer karma-html2js-preprocessor@0.0.2 wants karma@~0.9
npm ERR! peerinvalid Peer karma-jasmine@0.0.2 wants karma@~0.9
npm ERR! peerinvalid Peer karma-phantomjs-launcher@0.0.2 wants karma@~0.9
npm ERR! peerinvalid Peer karma-requirejs@0.0.2 wants karma@~0.9
npm ERR! peerinvalid Peer karma-script-launcher@0.0.2 wants karma@~0.9

Welcome in the dependency hell ;-) I've previously installed the canary version but I've uninstalled it before. How to install the new version 0.10?

Thanks!

@janbaer

This comment has been minimized.

Show comment
Hide comment
@janbaer

janbaer Aug 8, 2013

Is there any specific version of node.js required? I've tried the installation on my second MacBook and had no problem. The only difference is that there is an older version of node (0.8.x) installed. And on the first MacBook I've installed node.js in version 0.10.x.

janbaer commented Aug 8, 2013

Is there any specific version of node.js required? I've tried the installation on my second MacBook and had no problem. The only difference is that there is an older version of node (0.8.x) installed. And on the first MacBook I've installed node.js in version 0.10.x.

@collinforrester

This comment has been minimized.

Show comment
Hide comment
@collinforrester

collinforrester Aug 8, 2013

I'm also having the same error after trying to upgrade karma to 0.10. I deleted my local node_modules folder in my project and cleared npm cache before attempting.

npm ERR! peerinvalid The package karma does not satisfy its siblings' peerDependencies requirements!
npm ERR! peerinvalid Peer karma-chrome-launcher@0.1.0 wants karma@>=0.9.3
npm ERR! peerinvalid Peer karma-firefox-launcher@0.1.0 wants karma@>=0.9
npm ERR! peerinvalid Peer karma-html2js-preprocessor@0.1.0 wants karma@>=0.9
npm ERR! peerinvalid Peer karma-jasmine@0.1.0 wants karma@>=0.9
npm ERR! peerinvalid Peer karma-script-launcher@0.1.0 wants karma@>=0.9
npm ERR! peerinvalid Peer karma-requirejs@0.1.0 wants karma@>=0.9
npm ERR! peerinvalid Peer karma-junit-reporter@0.0.1 wants karma@~0.9
npm ERR! peerinvalid Peer karma-coffee-preprocessor@0.1.0 wants karma@>=0.9
npm ERR! peerinvalid Peer grunt-karma@0.6.1 wants karma@~0.10.0
npm ERR! peerinvalid Peer karma-phantomjs-launcher@0.1.0 wants karma@>=0.9
npm ERR! peerinvalid Peer karma-coverage@0.1.0 wants karma@>=0.9

I'm running node v0.10.12 and npm 1.2.32.

collinforrester commented Aug 8, 2013

I'm also having the same error after trying to upgrade karma to 0.10. I deleted my local node_modules folder in my project and cleared npm cache before attempting.

npm ERR! peerinvalid The package karma does not satisfy its siblings' peerDependencies requirements!
npm ERR! peerinvalid Peer karma-chrome-launcher@0.1.0 wants karma@>=0.9.3
npm ERR! peerinvalid Peer karma-firefox-launcher@0.1.0 wants karma@>=0.9
npm ERR! peerinvalid Peer karma-html2js-preprocessor@0.1.0 wants karma@>=0.9
npm ERR! peerinvalid Peer karma-jasmine@0.1.0 wants karma@>=0.9
npm ERR! peerinvalid Peer karma-script-launcher@0.1.0 wants karma@>=0.9
npm ERR! peerinvalid Peer karma-requirejs@0.1.0 wants karma@>=0.9
npm ERR! peerinvalid Peer karma-junit-reporter@0.0.1 wants karma@~0.9
npm ERR! peerinvalid Peer karma-coffee-preprocessor@0.1.0 wants karma@>=0.9
npm ERR! peerinvalid Peer grunt-karma@0.6.1 wants karma@~0.10.0
npm ERR! peerinvalid Peer karma-phantomjs-launcher@0.1.0 wants karma@>=0.9
npm ERR! peerinvalid Peer karma-coverage@0.1.0 wants karma@>=0.9

I'm running node v0.10.12 and npm 1.2.32.

@vojtajina

This comment has been minimized.

Show comment
Hide comment
@vojtajina

vojtajina Aug 8, 2013

Contributor

Karma runs on two latest stable versions of Node, that is 0.8.x or 0.10.x, so that's probably not the problem.

@janbaer I agree, that the peerDependencies are not as great as we thought... We need to fix NPM somehow, probably allow updating multiple packages at once or something...

Workaround: remove karma and all karma-* NPM modules first, eg. rm -rf /usr/local/lib/node_modules/karma-*.

I know, that this sucks, but I'm not sure how to fix this in Karma. Any ideas are welcome.

Also note that karma behaves similar to grunt-cli - if you have a local Karma instance, it will use it. So you can update only local version of Karma. I'm gonna push karma-cli to NPM, that at least avoid this dependency problems on the global packages level.

Contributor

vojtajina commented Aug 8, 2013

Karma runs on two latest stable versions of Node, that is 0.8.x or 0.10.x, so that's probably not the problem.

@janbaer I agree, that the peerDependencies are not as great as we thought... We need to fix NPM somehow, probably allow updating multiple packages at once or something...

Workaround: remove karma and all karma-* NPM modules first, eg. rm -rf /usr/local/lib/node_modules/karma-*.

I know, that this sucks, but I'm not sure how to fix this in Karma. Any ideas are welcome.

Also note that karma behaves similar to grunt-cli - if you have a local Karma instance, it will use it. So you can update only local version of Karma. I'm gonna push karma-cli to NPM, that at least avoid this dependency problems on the global packages level.

@janbaer

This comment has been minimized.

Show comment
Hide comment
@janbaer

janbaer Aug 8, 2013

Thank you for the tip to remove all the karma-* packages manually. This has solved my problem. The installation runs now without any problems.

janbaer commented Aug 8, 2013

Thank you for the tip to remove all the karma-* packages manually. This has solved my problem. The installation runs now without any problems.

@adben

This comment has been minimized.

Show comment
Hide comment
@adben

adben Aug 9, 2013

Should this workaround be added to the migration guide?

adben commented Aug 9, 2013

Should this workaround be added to the migration guide?

@collinforrester

This comment has been minimized.

Show comment
Hide comment
@collinforrester

collinforrester Aug 9, 2013

The workaround also works for windows (different path obviously). Thanks!

collinforrester commented Aug 9, 2013

The workaround also works for windows (different path obviously). Thanks!

@vojtajina

This comment has been minimized.

Show comment
Hide comment
@vojtajina

vojtajina Aug 18, 2013

Contributor

@adben A good idea. Added to the FAQ and migration docs.

I'm also closing this issue as I think we managed to find at least a workaround for it. I believe, we need to fix this in NPM, but I'm not sure how... ;-) Created an issue on NPM npm/npm#3803

Contributor

vojtajina commented Aug 18, 2013

@adben A good idea. Added to the FAQ and migration docs.

I'm also closing this issue as I think we managed to find at least a workaround for it. I believe, we need to fix this in NPM, but I'm not sure how... ;-) Created an issue on NPM npm/npm#3803

@vojtajina vojtajina closed this Aug 18, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment