Permalink
Browse files

[GEMS] Updated Turn dependency and relaxed ActiveRecord dependency ve…

…rsion

NOTE: Supermodel depends on ancient version ofActiveModel: 3.0. Replace with another "generic activemodel" or sort it out somehow.
  • Loading branch information...
1 parent e4a7e5a commit 24d58cbc34b1cfe0af9b90ee54f594402e0f533f @karmi committed Feb 4, 2012
Showing with 4 additions and 5 deletions.
  1. +1 −1 test/test_helper.rb
  2. +3 −4 tire.gemspec
View
@@ -7,7 +7,7 @@
require 'sqlite3'
require 'shoulda'
-require 'turn' unless ENV["TM_FILEPATH"] || ENV["CI"]
+require 'turn/autorun' unless ENV["TM_FILEPATH"] || ENV["CI"]
require 'mocha'
require 'active_support/core_ext/hash/indifferent_access'
View
@@ -38,18 +38,17 @@ Gem::Specification.new do |s|
s.add_development_dependency "yajl-ruby", "~> 0.8.0"
s.add_development_dependency "shoulda"
s.add_development_dependency "mocha"
- s.add_development_dependency "activerecord", "~> 3.0.7"
+ s.add_development_dependency "activerecord", "~> 3"
s.add_development_dependency "mongoid", "~> 2.2.1"
s.add_development_dependency "sqlite3"
- s.add_development_dependency "supermodel"
+ s.add_development_dependency "supermodel", "~> 0.1.6"
s.add_development_dependency "curb"
# These gems are not needed for CI at <http://travis-ci.org/#!/karmi/tire>
#
unless ENV["CI"]
s.add_development_dependency "rdoc"
- s.add_development_dependency "rcov"
- s.add_development_dependency "turn"
+ s.add_development_dependency "turn", "~> 0.9"
end
s.description = <<-DESC

0 comments on commit 24d58cb

Please sign in to comment.