An extended bootstrap alert and alert block widget for Yii2 (sub repo split from yii2-widgets)
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.github Updates to release v1.1.1 Mar 10, 2017
src Updates to release v1.1.2 Oct 9, 2018
CHANGE.md Updates to release v1.1.2 Oct 9, 2018
LICENSE.md Updates to release v1.1.2 Oct 9, 2018
README.md Update README Nov 5, 2018
composer.json Updates to release v1.1.2 Oct 9, 2018

README.md

Krajee Logo
yii2-widget-alert
Donate

Stable Version Unstable Version License Total Downloads Monthly Downloads Daily Downloads

This extension contains a couple of useful widgets. The Alert widget extends the \yii\bootstrap\Alert widget with more easy styling and auto fade out options. In addition, it includes a AlertBlock widget that groups multiple \kartik\widget\Alert or kartik\widget\Growl widgets in one single block and renders them stacked vertically on the current page. You can choose the TYPE_ALERT style or the TYPE_GROWL style for your notifications. You can also set the widget to automatically read and display session flash messages (which is the default setting). Alternatively, you can setup and configure your own block of custom alerts.

NOTE: This extension is a sub repo split of yii2-widgets. The split has been done since 08-Nov-2014 to allow developers to install this specific widget in isolation if needed. One can also use the extension the previous way with the whole suite of yii2-widgets.

Installation

The preferred way to install this extension is through composer. Check the composer.json for this extension's requirements and dependencies. Read this web tip /wiki on setting the minimum-stability settings for your application's composer.json.

To install, either run

$ php composer.phar require kartik-v/yii2-widget-alert "*"

or add

"kartik-v/yii2-widget-alert": "*"

to the require section of your composer.json file.

NOTE: Using Growl is optional and it is not automatically installed with this extension. If you want to use it in your project, you need to either run

$ php composer.phar require kartik-v/yii2-widget-growl "*"

or add

"kartik-v/yii2-widget-growl": "*"

to the require section of your composer.json file.

Refer the CHANGE LOG for details on changes to various releases.

Demo

You can refer detailed documentation and demos for Alert and AlertBlock widgets on usage of the extension.

Usage

Alert

use kartik\alert\Alert;

echo Alert::widget([
	'type' => Alert::TYPE_INFO,
	'title' => 'Note',
	'titleOptions' => ['icon' => 'info-sign'],
	'body' => 'This is an informative alert'
]);

AlertBlock

use kartik\alert\AlertBlock;

echo AlertBlock::widget([
	'type' => AlertBlock::TYPE_ALERT,
	'useSessionFlash' => true
]);

License

yii2-widget-alert is released under the BSD-3-Clause License. See the bundled LICENSE.md for details.