Skip to content
Inline lint highlighting for the Sublime Text editor
Python
Find file
Pull request Compare This branch is 4 commits ahead, 80 commits behind lunixbochs:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
sublimelint
.gitignore
README.markdown
sublimelint_plugin.py

README.markdown

Sublime Lint

A code-validating plugin with inline highlighting for the Sublime Text 2 editor.

Supports the following languages:

  • Python - native, moderately-complete lint

NOTE: the following languages may require you to install additional binaries and place them within your PATH (environment variable)

  • Coffescript - validation via "coffee --compile"
  • Java - validation via "java -Xlint" and a temporary file
  • PHP - syntax checking via "php -l"
  • Perl - syntax+deprecation checking via "perl -c"
  • Ruby - syntax checking via "ruby -wc"

Installing

Without Git: Download the latest source and copy sublimelint_plugin.py and the sublimelint/ folder to your Sublime Text "User" packages directory.

With Git: Clone the repository in your Sublime Text Packages directory (located one folder above the "User" directory)

git clone git://github.com/lunixbochs/sublimelint.git


The "User" packages directory is located at:

  • Windows: %APPDATA%/Sublime Text 2/Packages/User/
  • OS X: ~/Library/Application Support/Sublime Text 2/Packages/User/
  • Linux: ~/.config/sublime-text-2/User

You can also use the Preferences menu to open Package directories.

Something went wrong with that request. Please try again.