New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

.mew-alias gets lost occasionally #99

Open
pipapu opened this Issue Feb 21, 2016 · 0 comments

Comments

Projects
None yet
1 participant
@pipapu

pipapu commented Feb 21, 2016

I am running mew 6.7 on Emacs 24.5.1 under Ubuntu Linux 15.10.

My .mew-alias file occasionally gets lost: I find that email address expansion using [TAB] does not work as expected, and then I see that the .mew-alias file has gotten very small and contains only few
entries. If I notice it early enough, .mew-alias.old still contains the full information, but often I don't. Then I need to restore .mew-alias from a backup.

Unfortunately, I cannot pin down the precise conditions when this happens. I guess it is related to system or X.org crashes, but I just tried killing an active mew session doing "killall -9 emacs", and in this case .mew-alias did not get lost. So, it must be something more complicated, perhaps a race condition.

From my automatic backups, I see that the problem started exactly at the time of the upgrade to mew 6.7 (not 6.6) and persisted since then.

Further, my automatic backups indicate that, when .mew-alias gets lost, the file .mew-alias gets "deleted" (which probably means it does not simply get overwritten or it does not get re-created fast enough for my backup program not to notice).

Hope this helps to narrow down the problem. Let me know if you need me to do some more tests.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment