`cab outdated` confusing for multiple installed versions #1

Closed
hvr opened this Issue Aug 2, 2011 · 1 comment

2 participants

@hvr
hvr commented Aug 2, 2011

If I have multiple versions of a package installed, I can't see from cab outdateds output for which I haven't got the latest version installed. E.g.:

$ cab outdated
aeson 0.3.2.7 < 0.3.2.9
...

$ cabal info aeson
* aeson            (library)
    Synopsis:      Fast JSON parsing and encoding
    Versions available: 0.1.0.0, 0.2.0.0, 0.3.0.0, 0.3.1.0, 0.3.1.1, 0.3.2.6,
                        0.3.2.7, 0.3.2.8, 0.3.2.9 (and 6 others)
    Versions installed: 0.3.2.7, 0.3.2.9
    ...

So, aeson isn't really outdated, I just happen to have an old version lying around as well

@kazu-yamamoto

'outdated' means that a newer version is regeistered in HackageDB. So, the purpose of 'cab outdated' is tell you that a newer version is available. To see if the package is really not necessary, please use 'cab revdeps'.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment