Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
node.js rpm spec
Makefile

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
README.md
build.sh
node-js.centos5.configure.patch
nodejs.spec

README.md

node.js RPM spec

Building the RPM

Distro support

Tested working (as sane as I could test for) on:

  • RHEL/CentOS/SL/OL 6 x86_64
  • RHEL/CentOS/SL/OL 5 x86_64
  • Fedora 19 x86_64
  • This spec is tested under el6 and el5 only. However, Fedora15 or later work. maybe.

RHEL/CentOS/SL/OL 6

$ sudo yum install -y rpm-build rpmdevtools openssl-devel zlib-devel redhat-rpm-config gcc gcc-c++ make libstdc++-devel
$ rpmdev-setuptree

$ cd /path/to/nodejs-rpm # git dir
$ ./build.sh
$ cd ~/rpmbuild/RPMS/x86_64/
$ sudo yum install ./nodejs-X.X.X-X.el6.x86_64.rpm ./nodejs-npm-X.X.X-X.el6.x86_64.rpm --nogpgcheck

RHEL/CentOS/SL/OL 5

when you try to build on el5, must enable the EPEL repository.

$ sudo rpm -ivh http://dl.fedoraproject.org/pub/epel/5/x86_64/epel-release-5-4.noarch.rpm
$ sudo yum install -y rpm-build rpmdevtools openssl-devel zlib-devel python26 gcc gcc-c++ make libstdc++-devel
$ mkdir ~/rpmbuild
$ cd ~/rpmbuild
$ rpmdev-setuptree

$ cd /path/to/nodejs-rpm # git dir
$ ./build.sh
$ cd ~/rpmbuild/RPMS/x86_64/
$ sudo yum install ./nodejs-X.X.X-X.x86_64.rpm ./nodejs-npm-X.X.X-X.x86_64.rpm --nogpgcheck
Something went wrong with that request. Please try again.