Permalink
Browse files

- dependency on active support (good riddance! :) )

  • Loading branch information...
1 parent 40463d9 commit 246d398487d3cd36afbe5f3cbf722d66bdf25b86 @floere floere committed Jan 1, 2011
Showing with 10 additions and 23 deletions.
  1. +1 −2 Gemfile
  2. +9 −13 Gemfile.lock
  3. +0 −8 lib/phony.rb
View
@@ -2,8 +2,7 @@ source :gemcutter
source "http://rubygems.org"
gem 'rake'
-gem 'activesupport', '~> 3.0', :require => 'active_support/core_ext/object/blank'
group :test do
- gem 'rspec', '~> 2.0.0'
+ gem 'rspec', '~> 2.0'
end
View
@@ -2,24 +2,20 @@ GEM
remote: http://rubygems.org/
remote: http://rubygems.org/
specs:
- activesupport (3.0.1)
diff-lcs (1.1.2)
rake (0.8.7)
- rspec (2.0.1)
- rspec-core (~> 2.0.1)
- rspec-expectations (~> 2.0.1)
- rspec-mocks (~> 2.0.1)
- rspec-core (2.0.1)
- rspec-expectations (2.0.1)
- diff-lcs (>= 1.1.2)
- rspec-mocks (2.0.1)
- rspec-core (~> 2.0.1)
- rspec-expectations (~> 2.0.1)
+ rspec (2.3.0)
+ rspec-core (~> 2.3.0)
+ rspec-expectations (~> 2.3.0)
+ rspec-mocks (~> 2.3.0)
+ rspec-core (2.3.1)
+ rspec-expectations (2.3.0)
+ diff-lcs (~> 1.1.2)
+ rspec-mocks (2.3.0)
PLATFORMS
ruby
DEPENDENCIES
- activesupport (~> 3.0)
rake
- rspec (~> 2.0.0)
+ rspec (~> 2.0)
View
@@ -1,11 +1,3 @@
-begin
- gem 'activesupport', '~> 3.0'
-rescue LoadError
- puts "phony requires activesupport ~> 3.0"
-end
-
-require 'active_support/core_ext/object/blank'
-
# Framework.
#
require File.expand_path '../phony/vanity', __FILE__

0 comments on commit 246d398

Please sign in to comment.