New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

jquery.svgdom fixes for jquery 1.8.3 #8

Open
wants to merge 1 commit into
base: master
from

Conversation

Projects
None yet
9 participants
@micha149

micha149 commented Dec 14, 2012

I have fixed a lot of issues with the current jquery version 1.8.3 which occured in my project. This should also fix the most problems from issue kbwood/svg#5

Created a minified version with yui compressor, but this file was not tested!

@stoffeastrom

This comment has been minimized.

Show comment
Hide comment
@stoffeastrom

stoffeastrom Dec 14, 2012

+1
This looks good! Would be really good to get this in.

stoffeastrom commented Dec 14, 2012

+1
This looks good! Would be really good to get this in.

@micha149

This comment has been minimized.

Show comment
Hide comment
@micha149

micha149 Dec 14, 2012

It would be also great to have a bunch of unit tests to ensure, that fixes works correctly in all expected situations. I have used the jquery test suite to ensure that jquery core is not affected by the overrides of jquery.svgdom plugin. The functionality of jquery.svgdom could only be tested through our application, but it uses only a few features of the jquery.svg plugin.

micha149 commented Dec 14, 2012

It would be also great to have a bunch of unit tests to ensure, that fixes works correctly in all expected situations. I have used the jquery test suite to ensure that jquery core is not affected by the overrides of jquery.svgdom plugin. The functionality of jquery.svgdom could only be tested through our application, but it uses only a few features of the jquery.svg plugin.

@diogo-paschoal

This comment has been minimized.

Show comment
Hide comment
@diogo-paschoal

diogo-paschoal Jan 2, 2013

Hey hey, man. Very thanks.
Past month I've tested the svgdom plugin but it broke the twitter bootstrap, so I almost discarted it.
Today, googling for "addclass jquery.svgdom problem" I've found this post.
Starting the tests. If I get good news I'l bring it to you.
Thanks again. :)

diogo-paschoal commented Jan 2, 2013

Hey hey, man. Very thanks.
Past month I've tested the svgdom plugin but it broke the twitter bootstrap, so I almost discarted it.
Today, googling for "addclass jquery.svgdom problem" I've found this post.
Starting the tests. If I get good news I'l bring it to you.
Thanks again. :)

@rockcdr

This comment has been minimized.

Show comment
Hide comment
@rockcdr

rockcdr Feb 19, 2013

+1
Great. I am testing to make sure that it is OK for me.

rockcdr commented Feb 19, 2013

+1
Great. I am testing to make sure that it is OK for me.

@commonpike

This comment has been minimized.

Show comment
Hide comment
@commonpike

commonpike Mar 11, 2013

tested with jquery 1.9.0, still good. thanks!

one catch, but I'm not sure if that is in your patch or somewhere else in svgdom - in explorer7, jquery itself seemed to 'break without errors' - a lot of selectors werent working anymore. explorer8 was still fine.

since it wont work in ie<9 anyway, i'm including the scripts within (yuk) IE conditional comments.

commonpike commented Mar 11, 2013

tested with jquery 1.9.0, still good. thanks!

one catch, but I'm not sure if that is in your patch or somewhere else in svgdom - in explorer7, jquery itself seemed to 'break without errors' - a lot of selectors werent working anymore. explorer8 was still fine.

since it wont work in ie<9 anyway, i'm including the scripts within (yuk) IE conditional comments.

@doedje

This comment has been minimized.

Show comment
Hide comment
@doedje

doedje Mar 28, 2013

Hmm, does not work for me with jquery 1.9.1 since there is no $.browser anymore... (but here I am talking about jquery.svg.js and not jquery.svgdom.js, my bad) I'll fork the project and try to fix it...

Hmmm, this problem is already mentioned in issue #9 so I'll continue over there!

doedje commented Mar 28, 2013

Hmm, does not work for me with jquery 1.9.1 since there is no $.browser anymore... (but here I am talking about jquery.svg.js and not jquery.svgdom.js, my bad) I'll fork the project and try to fix it...

Hmmm, this problem is already mentioned in issue #9 so I'll continue over there!

@KOGI

This comment has been minimized.

Show comment
Hide comment
@KOGI

KOGI May 16, 2013

Thank you, @micha149! @kbwood, please merge this! :)

KOGI commented May 16, 2013

Thank you, @micha149! @kbwood, please merge this! :)

@JasonMore

This comment has been minimized.

Show comment
Hide comment
@JasonMore

JasonMore Jun 18, 2013

@kbwood should just give @micha149 push access if he's going to ignore pull requests.

JasonMore commented Jun 18, 2013

@kbwood should just give @micha149 push access if he's going to ignore pull requests.

mar10 added a commit to mar10/svg that referenced this pull request Feb 12, 2014

Applied pull request by micha149
Applied pull request kbwood#8 by micha149
@twitwi

This comment has been minimized.

Show comment
Hide comment
@twitwi

twitwi Mar 28, 2014

Thanks @micha149 for the patch and @mar10 for the fork.

It seems a bunch of functions disappeared in the patch, especially the load function (I use it for "remote" resource loading).
Was this intended? Anyone knows a workaround? Should I put it back in?

twitwi commented Mar 28, 2014

Thanks @micha149 for the patch and @mar10 for the fork.

It seems a bunch of functions disappeared in the patch, especially the load function (I use it for "remote" resource loading).
Was this intended? Anyone knows a workaround? Should I put it back in?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment