A module for installing sentry through puppet
Puppet
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
files
lib/puppet/parser/functions
manifests
templates
DOCUMENTATION.rdoc
Makefile
Modulefile
README.md

README.md

puppet-sentry

This is a puppet module for installing sentry.

One of the tricky things about installing sentry is that when you callsentry --config=foobar.py syncdb/upgrade, it will interactively ask you for superuser creation, which is not possible in puppet, since puppet runs in non-interactive mode.

puppet-sentry handles this problem by providing a predefined superuser object in json format, and an extra argument for sentry initialization. This way, you can install sentry with a predefined superuser without any interaction at all.

documentation

See the generated documentation for this module.