Cannot get to compile on Nodejitsu #158

Closed
Gacnt opened this Issue Apr 8, 2013 · 5 comments

Comments

Projects
None yet
3 participants

Gacnt commented Apr 8, 2013

https://gist.github.com/Gacnt/de76df0a05132ae7474c

Having a problem getting it to run on Nodejitsu, I posted in the jitsu IRC and they said create an issue here.

Locally everything runs fine and compiles great and works, ( Mac OS X 10.8.3)

Collaborator

ncb000gt commented Apr 8, 2013

That's strange. It is almost as if the file didn't download/extract on the nodejitsu server. Try clearing the module directory and pulling down/installing the modules again?

@TooTallNate any thoughts?

Gacnt commented Apr 8, 2013

@ncb000gt @TooTallNate https://gist.github.com/Gacnt/aa2fcb97afc16413476e Here is a full --debug from my attempt to deploy

I tried removing node_modules and running npm install again, worked great on my system, doesn't on theirs..

I've also tried setting my node engine to 0.8.x

Collaborator

ncb000gt commented Apr 13, 2013

So, in both gists it looks as like node 0.8.22 is being used to compile with:

gyp ERR! node -v v0.8.22

While it may be irrelevant you might want to try and get that set to the version your trying to use. Also, I believe node-gyp is at 0.9.9 now and it might be good to update that. Update those and check back if nothing improves.

Gacnt commented Apr 13, 2013

@ncb000gt it's been fixed thanks it was xauss I had a binding. Gyp file in my root directory

Collaborator

ncb000gt commented Apr 13, 2013

Wonderful. Thanks.
On Apr 13, 2013 1:44 AM, "Gacnt" notifications@github.com wrote:

@ncb000gt https://github.com/ncb000gt it's been fixed thanks it was
xauss I had a binding. Gyp file in my root directory


Reply to this email directly or view it on GitHubhttps://github.com/ncb000gt/node.bcrypt.js/issues/158#issuecomment-16328021
.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment