update dependency listing in readme.md for Windows #95

Closed
dhodgin opened this Issue Aug 10, 2012 · 1 comment

Comments

Projects
None yet
2 participants

dhodgin commented Aug 10, 2012

There is no mention that Python is required to install bcrypt.

Not sure if this is just for windows and which version is required but I installed Python 2.7.3 and got past the error that the installer could not find python. Is 2.7.3 the correct version or should I have python 3.x?

Also, to get this to build on Windows you need to have the visual studio cl.exe compiler available. If you did not check the options for c# and c++ when installing visual studio this compiler wont exist and you will get an error.

Once I added those options from the installer for VS2010 I reinstall vs 2008 c++ redistributables to be safe and ran npm install bcrypt from msysgit (MINGW32) and it installed successfully.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment