Permalink
Browse files

[Fix] Remove requirement for 'dm-more' 


Minor cleanups
  • Loading branch information...
1 parent 892c9a7 commit 5867d3b1beec4779e3d24db9379a797f5b1d8a9c @kematzy committed May 20, 2010
Showing with 12 additions and 17 deletions.
  1. +3 −2 Rakefile
  2. +8 −11 dm-is-select.gemspec
  3. +0 −1 spec/spec.opts
  4. +1 −3 spec/spec_helper.rb
View
@@ -12,8 +12,8 @@ begin
gem.homepage = "http://github.com/kematzy/dm-is-select"
gem.authors = ["kematzy"]
gem.extra_rdoc_files = %w[ README.rdoc LICENSE TODO History.rdoc ]
- gem.add_dependency('dm-core', '>= 0.10.0')
- gem.add_dependency('dm-more', '>= 0.10.0')
+ gem.add_dependency('dm-core', '>= 0.10.2')
+ # gem.add_dependency('dm-more', '>= 0.10.0')
# gem.add_dependency('dm-validations', '>= 0.10.0')
# gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
@@ -26,6 +26,7 @@ end
require 'spec/rake/spectask'
Spec::Rake::SpecTask.new(:spec) do |spec|
spec.libs << 'lib' << 'spec'
+ spec.spec_opts = ["--color", "--format", "nested", "--require", "spec/spec_helper.rb"]
spec.spec_files = FileList['spec/**/*_spec.rb']
end
View
@@ -1,6 +1,6 @@
# Generated by jeweler
-# DO NOT EDIT THIS FILE
-# Instead, edit Jeweler::Tasks in Rakefile, and run `rake gemspec`
+# DO NOT EDIT THIS FILE DIRECTLY
+# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["kematzy"]
- s.date = %q{2009-12-21}
+ s.date = %q{2010-05-20}
s.description = %q{A DataMapper plugin that makes getting the <tt>select</tt> options from a Model easier.}
s.email = %q{kematzy@gmail.com}
s.extra_rdoc_files = [
@@ -31,13 +31,12 @@ Gem::Specification.new do |s|
"lib/dm-is-select/is/select.rb",
"lib/dm-is-select/is/version.rb",
"spec/integration/select_spec.rb",
- "spec/spec.opts",
"spec/spec_helper.rb"
]
s.homepage = %q{http://github.com/kematzy/dm-is-select}
s.rdoc_options = ["--charset=UTF-8"]
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.5}
+ s.rubygems_version = %q{1.3.6}
s.summary = %q{A DataMapper plugin that makes getting the <tt>select</tt> options from a Model easier.}
s.test_files = [
"spec/integration/select_spec.rb",
@@ -49,14 +48,12 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<dm-core>, [">= 0.10.0"])
- s.add_runtime_dependency(%q<dm-more>, [">= 0.10.0"])
+ s.add_runtime_dependency(%q<dm-core>, [">= 0.10.2"])
else
- s.add_dependency(%q<dm-core>, [">= 0.10.0"])
- s.add_dependency(%q<dm-more>, [">= 0.10.0"])
+ s.add_dependency(%q<dm-core>, [">= 0.10.2"])
end
else
- s.add_dependency(%q<dm-core>, [">= 0.10.0"])
- s.add_dependency(%q<dm-more>, [">= 0.10.0"])
+ s.add_dependency(%q<dm-core>, [">= 0.10.2"])
end
end
+
View
@@ -1 +0,0 @@
---colour
View
@@ -1,10 +1,8 @@
require 'pathname'
require 'rubygems'
-gem 'rspec', '~>1.2.6'
+# gem 'rspec', '~>1.2.6'
require 'spec'
-# gem 'dm-is-tree', '~>0.10.0'
-# require 'dm-is-tree'
require Pathname(__FILE__).dirname.expand_path.parent + 'lib/dm-is-select'

0 comments on commit 5867d3b

Please sign in to comment.