Jquery.js is correct, but google cdn version is still 1.8.3 #15

Closed
9mm opened this Issue Jan 31, 2013 · 5 comments

Projects

None yet

5 participants

9mm commented Jan 31, 2013

I'm not sure if this is a problem on my end (or something to do with jquery-rails), but in my app, the code jquery-rails-cdn generates seems to be off by a version. For the ajax.googleapis.com URL it says 1.8.3, but for local precompiled version (jquery.js) its the correct version (1.9.0)

Thanks!

Having the same issue..

Owner
kenn commented Feb 3, 2013

Waiting for the fix from rails/jquery-rails#97

@kenn kenn referenced this issue in rails/jquery-rails Feb 3, 2013
Merged

Fix jQuery version constant #97

ffmike commented Feb 5, 2013

I took a quick and dirty pass at allowing the version to be overridden from within the Rails application at ffmike@40f4850

I don't think this is necessarily the best approach, but there it is for anyone who needs this now. Perhaps it'll inspire a cleaner solution in the master. I do think it's useful, especially in a production setting, to be able to control this precisely on an environment-by-environment basis.

Owner
kenn commented Feb 8, 2013

Now jquery-rails 2.2.1 is out. Closing.

@kenn kenn closed this Feb 8, 2013

Is there a way to specify the jquery version you want to use? 2.0 is now out. I could use @ffmike version...

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment