Permalink
Browse files

Merge branch 'convert-to-bundler'

  • Loading branch information...
2 parents e0dbe93 + bd831fb commit 9dbd03655e079530c8e8eb5b60dc520d8f3f9711 @marcbowes marcbowes committed Oct 30, 2011
View
@@ -1,5 +1,17 @@
-*#*
-pkg/
-tmp/
+*.gem
+*.rbc
+.bundle
+.config
+.yardoc
+Gemfile.lock
+InstalledFiles
+_yardoc
+coverage
doc/
-*.swp
+lib/bundler/man
+pkg
+rdoc
+spec/reports
+test/tmp
+test/version_tmp
+tmp
View
20 Gemfile
@@ -1,18 +1,4 @@
-source "http://rubygems.org"
+source 'http://rubygems.org'
-gem "eventmachine", ">= 0.12.10"
-gem "safely"
-
-group :development do
- gem "jeweler", "~> 1.6.0"
-end
-
-group :development, :test do
- gem "SyslogLogger"
-end
-
-group :test do
- gem "rspec", "~> 2.6"
- gem "cucumber", "~> 0.10.0"
- gem "mocha", "~> 0.9.12"
-end
+# Specify your gem's dependencies in daemon-kit.gemspec
+gemspec
View
@@ -1,3 +1,10 @@
+PATH
+ remote: .
+ specs:
+ daemon-kit (0.1.8.2)
+ eventmachine (>= 0.12.10)
+ safely (>= 0.3.1)
+
GEM
remote: http://rubygems.org/
specs:
@@ -14,16 +21,13 @@ GEM
eventmachine (0.12.10)
gherkin (2.3.5)
json (>= 1.4.6)
- git (1.2.5)
hoe (2.9.4)
rake (>= 0.8.7)
- jeweler (1.6.0)
- bundler (~> 1.0.0)
- git (>= 1.2.5)
- rake
json (1.5.1)
mocha (0.9.12)
rake (0.8.7)
+ rdoc (3.11)
+ json (~> 1.4)
rspec (2.6.0)
rspec-core (~> 2.6.0)
rspec-expectations (~> 2.6.0)
@@ -32,17 +36,18 @@ GEM
rspec-expectations (2.6.0)
diff-lcs (~> 1.1.2)
rspec-mocks (2.6.0)
- safely (0.3.0)
+ safely (0.3.1)
term-ansicolor (1.0.5)
PLATFORMS
ruby
DEPENDENCIES
SyslogLogger
+ bundler
cucumber (~> 0.10.0)
- eventmachine (>= 0.12.10)
- jeweler (~> 1.6.0)
+ daemon-kit!
mocha (~> 0.9.12)
+ rake
+ rdoc
rspec (~> 2.6)
- safely
View
@@ -1,25 +1,7 @@
-Dir['tasks/**/*.rake'].each { |t| load t }
-
-require File.dirname(__FILE__) + '/lib/daemon_kit'
+#!/usr/bin/env rake
+require "bundler/gem_tasks"
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gemspec|
- gemspec.name = 'daemon-kit'
- gemspec.version = DaemonKit::VERSION
- gemspec.summary = 'Opinionated framework for Ruby daemons'
- gemspec.description = 'daemon-kit aims to simplify creating Ruby daemons by providing a sound application skeleton (through a generator), task specific generators (jabber bot, etc) and robust environment management code.'
- gemspec.email = 'kenneth.kalmer@gmail.com'
- gemspec.homepage = 'http://github.com/kennethkalmer/daemon-kit'
- gemspec.authors = ['kenneth.kalmer@gmail.com']
- gemspec.post_install_message = IO.read('PostInstall.txt')
- gemspec.extra_rdoc_files.include '*.txt'
- gemspec.files.include("lib/generators/**/*", "lib/daemon_kit/vendor/**/*")
- end
- Jeweler::GemcutterTasks.new
-rescue LoadError
- puts "Jeweler not available. Install it with 'gem install jeweler'"
-end
+Dir['tasks/**/*.rake'].each { |t| load t }
# TODO - want other tests/tasks run by default? Add them to the list
task :default => [:spec] #, :features]
View
@@ -8,7 +8,7 @@ rescue LoadError
end
if %w(-v --version).include? ARGV.first
- puts "#{File.basename($0)} #{DaemonKit::VERSION} (http://github.com/kennethkalmer/daemon-kit)"
+ puts "#{File.basename($0)} #{DaemonKit.version} (http://github.com/kennethkalmer/daemon-kit)"
exit(0)
end
Oops, something went wrong.

0 comments on commit 9dbd036

Please sign in to comment.