Permalink
Browse files

Ladies and gentleman: 0.1.8

  • Loading branch information...
1 parent 08b0911 commit a8783c43f477e0c9ce0d80123f4ba4c3c6b8eee0 @kennethkalmer committed Aug 3, 2010
Showing with 13 additions and 7 deletions.
  1. +3 −1 History.txt
  2. +6 −2 README.rdoc
  3. +3 −3 daemon-kit.gemspec
  4. +1 −1 lib/daemon_kit.rb
View
4 History.txt
@@ -1,4 +1,4 @@
-== 0.1.18 (WIP)
+== 0.1.18 2010-08-03
* Generators rewritten to use Thor
* Evented XMPP now handled by blather
@@ -9,6 +9,8 @@
* Removed support for exception emails
* Improved log rotation support [mperham]
* Initial 1.9.2 support
+* Exception handling for scheduled tasks (cron)
+* Updates for ruote-amqp versions 2.1 and later
== 0.1.7.12 2009-12-04
View
8 README.rdoc
@@ -66,8 +66,8 @@ The ruote[http://openwfe.rubyforge.org] remote participant generator speeds up t
== Requirements
-* Ruby 1.8.6 or later (developed on 1.9.1)
-* eventmachine-0.12.8[http://rubyeventmachine.com]
+* Ruby 1.8.7 or later (developed on REE/1.9.1)
+* eventmachine-0.12.10[http://rubyeventmachine.com]
* rspec (for writing/running your specs)
== Generator Requirements
@@ -94,6 +94,10 @@ Stable versions, when released are available directly from Gemcutter:
$ gem install daemon-kit
+== Upgrading
+
+When upgrading daemons generated from earlier versions of daemon-kit, it is easier in most cases to re-generate the daemon. Since 0.1.8 the generators use Thor, which allows you to review a diff of each file before deciding to overwrite it.
+
== Further reading
* Configuration.txt
View
6 daemon-kit.gemspec
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = %q{daemon-kit}
- s.version = "0.1.8rc3"
+ s.version = "0.1.8"
- s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
+ s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["kenneth.kalmer@gmail.com"]
- s.date = %q{2010-07-23}
+ s.date = %q{2010-08-03}
s.default_executable = %q{daemon-kit}
s.description = %q{daemon-kit aims to simplify creating Ruby daemons by providing a sound application skeleton (through a generator), task specific generators (jabber bot, etc) and robust environment management code.}
s.email = %q{kenneth.kalmer@gmail.com}
View
2 lib/daemon_kit.rb
@@ -13,7 +13,7 @@
$LOAD_PATH.include?( File.dirname(__FILE__).to_absolute_path )
module DaemonKit
- VERSION = '0.1.8rc3'
+ VERSION = '0.1.8'
autoload :Initializer, 'daemon_kit/initializer'
autoload :Application, 'daemon_kit/application'

0 comments on commit a8783c4

Please sign in to comment.