Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

cannot install legit from pip #120

Open
cyluss opened this Issue · 10 comments

7 participants

@cyluss

I cannot install legit from pip.

The setup script could not find proper gitpython version.

Please fix this issue.

vagrant@precise32:~$ sudo pip install legit
Downloading/unpacking legit
  Downloading legit-0.1.1.tar.gz
  Running setup.py egg_info for package legit

Downloading/unpacking clint>=0.2.4 (from legit)
  Downloading clint-0.3.1.tar.gz
  Running setup.py egg_info for package clint

Downloading/unpacking gitpython>=0.3.0 (from legit)
  Could not find a version that satisfies the requirement gitpython>=0.3.0 (from legit) (from versions: 0.1.7, 0.2.0-beta1, 0.3.0-beta1, 0.3.0-beta2, 0.3.1-beta2, 0.3.2.RC1)
Cleaning up...
No distributions matching the version for gitpython>=0.3.0 (from legit)
Storing complete log in /home/vagrant/.pip/pip.log
vagrant@precise32:~$ 
@cyluss

Replacing gitpython>=0.3.0 to gitpython>=0.3.0-beta in reqs.txt fixes the issue.

@TCattd

I was having the same problem.
Fresh Ubuntu 13.10 x64

I can confirm that changin reqs.txt let legit be installed.
Just get the package from https://pypi.python.org/pypi/legit/ and extract the reqs.txt from the tar.gz

Then to install legit run:

sudo pip install legit -r reqs.txt && sudo legit install

Thanks @cyluss for the tip ;)

@wiseman

Same problem in OS X using python 2.7.5.

@nickbaum

FYI, still seeing the same error when installing from pip:

Downloading/unpacking gitpython>=0.3.0 (from legit)
Could not find a version that satisfies the requirement gitpython>=0.3.0 (from legit) (from versions: 0.1.7, 0.2.0-beta1, 0.3.0-beta1, 0.3.0-beta2, 0.3.1-beta2, 0.3.2.RC1)
Cleaning up...
No distributions matching the version for gitpython>=0.3.0 (from legit)

@wenLiangcan

I got the error too:

Downloading/unpacking gitpython>=0.3.0 (from legit)
Real name of requirement gitpython is GitPython
Could not find a version that satisfies the requirement gitpython>=0.3.0 (from legit) (from versions: 0.3.0-beta1, 0.1.7, 0.2.0-beta1, 0.3.0-beta2, 0.3.1-beta2, 0.3.2.RC1)
Cleaning up...
No distributions matching the version for gitpython>=0.3.0 (from legit)

@suan

Same here...

@streetdaddy

+1

cat reqs.txt
clint>=0.2.4
gitpython>=0.3.0-beta

sudo pip install legit -r reqs.txt && sudo legit install
Password:
Requirement already satisfied (use --upgrade to upgrade): legit in /Library/Python/2.7/site-packages
Requirement already satisfied (use --upgrade to upgrade): clint>=0.2.4 in /Library/Python/2.7/site-packages (from -r reqs.txt (line 1))
Requirement already satisfied (use --upgrade to upgrade): gitpython>=0.3.0-beta in /Library/Python/2.7/site-packages (from -r reqs.txt (line 2))
Requirement already satisfied (use --upgrade to upgrade): gitdb>=0.5.0 in /Library/Python/2.7/site-packages (from gitpython>=0.3.0-beta->-r reqs.txt (line 2))
Requirement already satisfied (use --upgrade to upgrade): async>=0.6.1 in /Library/Python/2.7/site-packages (from gitdb>=0.5.0->gitpython>=0.3.0-beta->-r reqs.txt (line 2))
Requirement already satisfied (use --upgrade to upgrade): smmap>=0.8.0 in /Library/Python/2.7/site-packages (from gitdb>=0.5.0->gitpython>=0.3.0-beta->-r reqs.txt (line 2))
Cleaning up...
Traceback (most recent call last):
File "/usr/local/bin/legit", line 5, in
from pkg_resources import load_entry_point
File "build/bdist.macosx-10.9-intel/egg/pkg_resources.py", line 2797, in

File "build/bdist.macosx-10.9-intel/egg/pkg_resources.py", line 576, in resolve
plugin_env, full_env=None, installer=None, fallback=True
pkg_resources.DistributionNotFound: gitpython>=0.3.0

@streetdaddy

How I fixed this (with reqs.txt having gitpython>=0.3.0-beta):

sudo pip uninstall gitpython
sudo pip install -Iv https://pypi.python.org/packages/source/G/GitPython/GitPython-0.3.1-beta2.tar.gz
pip list | grep -i gitpython

GitPython (0.3.1)

sudo pip install legit -r reqs.txt && sudo legit install

Requirement already satisfied (use --upgrade to upgrade): legit in /Library/Python/2.7/site-packages
Requirement already satisfied (use --upgrade to upgrade): clint>=0.2.4 in /Library/Python/2.7/site-packages (from -r reqs.txt (line 1))
Requirement already satisfied (use --upgrade to upgrade): gitpython>=0.3.0-beta in /Library/Python/2.7/site-packages (from -r reqs.txt (line 2))
Requirement already satisfied (use --upgrade to upgrade): gitdb>=0.5.1 in /Library/Python/2.7/site-packages (from gitpython>=0.3.0-beta->-r reqs.txt (line 2))
Requirement already satisfied (use --upgrade to upgrade): async>=0.6.1 in /Library/Python/2.7/site-packages (from gitdb>=0.5.1->gitpython>=0.3.0-beta->-r reqs.txt (line 2))
Requirement already satisfied (use --upgrade to upgrade): smmap>=0.8.0 in /Library/Python/2.7/site-packages (from gitdb>=0.5.1->gitpython>=0.3.0-beta->-r reqs.txt (line 2))
Cleaning up...
The following git aliases have been installed:

git switch '!legit switch "$@"'
git branches '!legit branches'
git sprout '!legit sprout "$@"'
git unpublish '!legit unpublish "$@"'
git harvest '!legit harvest "$@"'
git sync '!legit sync "$@"'
git publish '!legit publish "$@"'
git graft '!legit graft "$@"'

@nickbaum

FYI, Legit still won't install cleanly from pip:

Downloading/unpacking gitpython>=0.3.0 (from legit)
  Could not find a version that satisfies the requirement gitpython>=0.3.0 (from legit) (from versions: 0.1.7, 0.2.0-beta1, 0.3.0-beta1, 0.3.0-beta2, 0.3.1-beta2, 0.3.2.RC1)
Cleaning up...
No distributions matching the version for gitpython>=0.3.0 (from legit)

This is probably one of those issues that are worse than they seem: many people likely run into this error and never find the workaround, so you never hear from them and they miss out on the legit awesomeness :(

@wiseman

Also see issues #127 and #144 which are about the same problem.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.