Skip to content
Permalink
Browse files

fix: bumped cross-spawn to version 7.0.0 (#211)

* bumped cross-spawn to version 7.0.0 and added a warning about node.js 7 and lower

* package.json, engines node : ">=8.0"

BREAKING CHANGE: Drop support for Node.js < 7.
  • Loading branch information...
bibo5088 authored and kentcdodds committed Sep 17, 2019
1 parent a75fd0e commit 61ebf5970e88e915a09e80d0858ca6344efaa3ae
Showing with 5 additions and 2 deletions.
  1. +3 −0 README.md
  2. +2 −2 package.json
@@ -54,6 +54,9 @@ npm install --save-dev cross-env
> WARNING! Make sure that when you're installing packages that you spell things
> correctly to avoid [mistakenly installing malware][malware]
> NOTE : Version 6 of cross-env only supports Node.js 8 and higher, to use it on Node.js 7 or lower install version 5
> ```npm install --save-dev cross-env@5 ```
## Usage

I use this in my npm scripts:
@@ -9,7 +9,7 @@
"cross-env-shell": "dist/bin/cross-env-shell.js"
},
"engines": {
"node": ">=4.0"
"node": ">=8.0"
},
"scripts": {
"add-contributor": "kcd-scripts contributors add",
@@ -25,7 +25,7 @@
"author": "Kent C. Dodds <kent@doddsfamily.us> (http://kentcdodds.com/)",
"license": "MIT",
"dependencies": {
"cross-spawn": "^6.0.5"
"cross-spawn": "^7.0.0"
},
"devDependencies": {
"kcd-scripts": "^0.3.4"

0 comments on commit 61ebf59

Please sign in to comment.
You can’t perform that action at this time.