Permalink
Commits on Aug 16, 2014
  1. @kentfredric

    post-release cleanup

    kentfredric committed Aug 16, 2014
  2. @kentfredric

    v0.5.2

     [00 Trivial]
     - CPANDAY!
     - No code changes.
     - metadata updated.
     - tests updated.
     - whitespace reduced.
    
     [Dependencies::Noteworthy]
     - use newer Path::Tiny to avoid bug GH #7 ( Thanks Chorny )
    
     [Dependencies::Stats]
     - Dependencies changed since 0.5.1, see misc/*.deps* for details
     - configure: ↓1
     - develop: +1 (suggests: ↑1)
     - runtime: ↑1
     - test: +1 -3 (recommends: ↑1 -1)
    
     [Metadata]
     - move to kentnl org.
     - Show 2x contributors
    
     [Misc]
     - Improve source side POD to reduce build side whitespace.
    
     [Tests]
     - updated Test::ReportPrereqs
    kentfredric committed Aug 16, 2014
  3. @kentfredric

    reduce whitespace

    kentfredric committed Aug 16, 2014
  4. @kentfredric

    Autodeps

    kentfredric committed Aug 16, 2014
  5. @kentfredric

    Travis

    kentfredric committed Aug 16, 2014
Commits on Jul 13, 2014
  1. @kentfredric

    Post release tweaks

    kentfredric committed Jul 13, 2014
  2. @kentfredric

    v0.5.1

     [00 Trivial]
     - Misc packaging updates.
    
     [Dependencies::Stats]
     - Dependencies changed since 0.5.0, see misc/*.deps* for details
     - configure: (recommends: ↑1)
     - develop: +3 -3 (suggests: +2 -1)
     - test: (recommends: ↑2)
    kentfredric committed Jul 13, 2014
  3. @kentfredric

    Update perlcritic tools

    kentfredric committed Jul 13, 2014
  4. @kentfredric

    Update Changes

    kentfredric committed Jul 13, 2014
  5. @kentfredric

    Add LICENSE

    kentfredric committed Jul 13, 2014
  6. @kentfredric

    Update Changes

    kentfredric committed Jul 13, 2014
  7. @kentfredric

    Switch to bumpversions

    kentfredric committed Jul 13, 2014
  8. @kentfredric

    update travis conf

    kentfredric committed Jul 13, 2014
  9. @kentfredric

    Nuke subrepo

    kentfredric committed Jul 13, 2014
  10. @kentfredric

    Bake ini

    kentfredric committed Jul 13, 2014
Commits on Mar 4, 2014
  1. @kentfredric

    v0.5.0

     [00 Tooling release]
     - Toolkit switched to EUMM
     - No other noteworthy changes
     - Still as broken as always
    
     [Dependencies::Aggregate]
     - 5.008 - 49 → 44
     - 5.010 - 32 → 33
     - 5.019 - 18 → 17
    
     [Dependencies::Stats]
     - Dependencies changed since 0.4.2, see Changes.deps{,.all,.dev} for
       details
     - build: -1
     - configure: +2 -1
     - develop: +8 ↑1 -10
     - runtime: +1 ↑1
     - test: +8 ↓1 -3
    kentfredric committed Mar 4, 2014
  2. @kentfredric

    Add aggregate data

    kentfredric committed Mar 4, 2014
Commits on Mar 3, 2014
  1. @kentfredric
  2. @kentfredric
  3. @kentfredric

    remove C<> in apropos

    kentfredric committed Mar 3, 2014
  4. @kentfredric
  5. @kentfredric

    remove redundant variables

    kentfredric committed Mar 3, 2014
  6. @kentfredric

    Update critic config

    kentfredric committed Mar 3, 2014
  7. @kentfredric

    use 5.008 and utf8

    kentfredric committed Mar 3, 2014
  8. @kentfredric

    Update perlcritic conf

    kentfredric committed Mar 3, 2014
  9. @kentfredric

    Add #AUTHORITY comments

    kentfredric committed Mar 3, 2014
  10. @kentfredric

    Update tooling to EUMM

    kentfredric committed Mar 3, 2014
  11. @kentfredric

    Update travis yml conf

    kentfredric committed Mar 3, 2014
  12. @kentfredric

    git subrepo clone https://github.com/kentfredric/travis-scripts.git m…

    …aint-travis-ci
    
    {"local":
      {"subdir":  "maint-travis-ci"
      ,"action":  "clone"}
    ,"remote":
      {"url":     "https://github.com/kentfredric/travis-scripts.git"
      ,"branch":  "master"
      ,"commit":  "7c80dff"}
    ,"git-subrepo":
      {"version": "0.1.0"
      ,"commit":  "b7cea56"
      ,"origin":  "git@github.com:git-commands/git-subrepo.git"}}
    kentfredric committed Mar 3, 2014
  13. @kentfredric

    remove submodule

    kentfredric committed Mar 3, 2014
Commits on Nov 9, 2013
  1. @kentfredric

    v0.4.2

     [00 Bugfix]
     - Minimum perl declared is now 5.8, and tested to work on 5.8
     - However, the version scheme is x.y.z still, which means if you want to
       depend on a specific version in Perl code, you'll need a recent enough
       version.pm to make it work.
    
     [Dependencies::Added / develop requires]
     - Dist::Zilla::Plugin::Author::KENTNL::MinimumPerl
     - Dist::Zilla::Plugin::Authority 1.006
     - Dist::Zilla::Plugin::AutoPrereqs
     - Dist::Zilla::Plugin::CheckExtraTests
     - Dist::Zilla::Plugin::ConfirmRelease
     - Dist::Zilla::Plugin::EOLTests
     - Dist::Zilla::Plugin::Git::Check
     - Dist::Zilla::Plugin::Git::Commit
     - Dist::Zilla::Plugin::Git::CommitBuild
     - Dist::Zilla::Plugin::Git::GatherDir
     - Dist::Zilla::Plugin::Git::NextVersion
     - Dist::Zilla::Plugin::Git::Tag
     - Dist::Zilla::Plugin::GithubMeta
     - Dist::Zilla::Plugin::License
     - Dist::Zilla::Plugin::Manifest
     - Dist::Zilla::Plugin::ManifestSkip
     - Dist::Zilla::Plugin::MetaConfig
     - Dist::Zilla::Plugin::MetaData::BuiltWith
     - Dist::Zilla::Plugin::MetaJSON
     - Dist::Zilla::Plugin::MetaProvides::Package 1.14000001
     - Dist::Zilla::Plugin::MetaTests
     - Dist::Zilla::Plugin::MetaYAML
     - Dist::Zilla::Plugin::ModuleBuild
     - Dist::Zilla::Plugin::NextRelease
     - Dist::Zilla::Plugin::PkgVersion
     - Dist::Zilla::Plugin::PodCoverageTests
     - Dist::Zilla::Plugin::PodSyntaxTests
     - Dist::Zilla::Plugin::PodWeaver
     - Dist::Zilla::Plugin::Prereqs
     - Dist::Zilla::Plugin::Prereqs::MatchInstalled
     - Dist::Zilla::Plugin::PruneCruft
     - Dist::Zilla::Plugin::ReadmeAnyFromPod
     - Dist::Zilla::Plugin::ReadmeFromPod
     - Dist::Zilla::Plugin::ReportVersions::Tiny
     - Dist::Zilla::Plugin::Test::CPAN::Changes
     - Dist::Zilla::Plugin::Test::Compile
     - Dist::Zilla::Plugin::Test::Kwalitee
     - Dist::Zilla::Plugin::Test::MinimumVersion
     - Dist::Zilla::Plugin::Test::Perl::Critic
     - Dist::Zilla::Plugin::TestRelease
     - Dist::Zilla::Plugin::Twitter
     - Dist::Zilla::Plugin::UploadToCPAN
    
     [Dependencies::Changed / build requires]
     - Module::Build 0.4007 → 0.4008
    
     [Dependencies::Changed / configure requires]
     - Module::Build 0.4007 → 0.4008
    
     [Dependencies::Changed / develop requires]
     - Dist::Zilla::PluginBundle::Author::KENTNL 2.000000 → 2.001000
    
     [Dependencies::Changed / runtime requires]
     - perl v5.10.0 → 5.006
    
     [Dependencies::Changed / test requires]
     - Test::More 0.99 → 1.001002
    kentfredric committed Nov 9, 2013
  2. @kentfredric

    Update Changelog

    kentfredric committed Nov 9, 2013
  3. @kentfredric
  4. @kentfredric
  5. @kentfredric