New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cold start sometimes safe boots #1

Closed
keptenkurk opened this Issue Mar 12, 2018 · 1 comment

Comments

Projects
None yet
1 participant
@keptenkurk
Owner

keptenkurk commented Mar 12, 2018

At about half of the cold-starts the LoPy goes into cold-start mode (flashing orange led).
Upon investigation this might well be caused by using P12 for serial communication.
If P12 is held high during boot, main,py will be skipped.

Better move the GPS serial comms to (P3,P4) instead.

@keptenkurk keptenkurk added the bug label Mar 12, 2018

@keptenkurk keptenkurk changed the title from Cold start sometimes save boots to Cold start sometimes safe boots Mar 13, 2018

keptenkurk added a commit that referenced this issue Apr 2, 2018

Move UART1 (GPS) to default pins
See issue #1: P12 is used to cold boot when active. If powered up the GPS will immidiately start sending
@keptenkurk

This comment has been minimized.

Owner

keptenkurk commented Apr 2, 2018

Fixed by rewiring to P3,P4 and changing the config.py. uart1 now at default pins. Problem not seen again. Also the wiring did not correspond to the picture in the documentation.

@keptenkurk keptenkurk closed this Apr 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment