Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

RESOLVED - 358496: Drop support for eclipse 3.5

  • Loading branch information...
commit 019dacc12d4cca123886abbc50ac9b3131bdf071 1 parent 02f21df
@ketan authored
View
8 .gitignore
@@ -32,19 +32,11 @@ org.eclipse.swtbot.updatesite/build/
/swtbot/
-org.eclipse.swtbot.junit4_x/.classpath
-org.eclipse.swtbot.junit4_x/META-INF/MANIFEST.MF
-org.eclipse.swtbot.junit4_x/build.properties
-
-org.eclipse.swtbot.eclipse.ui/META-INF/MANIFEST.MF
-
org.eclipse.swtbot.releng/test-sandbox/passFail.txt
org.eclipse.swtbot.releng/test-sandbox/org.eclipse.swtbot.eclipse.ui.test.ser
org.eclipse.swtbot.swt.finder.test/keyboard.layout
org.eclipse.swtbot.swt.finder.test/keyboard.layout.filtered
-org.eclipse.swtbot.eclipse.ui/.classpath
-org.eclipse.swtbot.eclipse.ui/build.properties
/eclipse-3.4/
/eclipse-3.5/
/eclipse/
View
0  org.eclipse.swtbot.eclipse.ui/_classpath.eclipse_3_5 → org.eclipse.swtbot.eclipse.ui/.classpath
File renamed without changes
View
0  ...tbot.eclipse.ui/META-INF/_MANIFEST.MF_eclipse_3_6 → org.eclipse.swtbot.eclipse.ui/META-INF/MANIFEST.MF
File renamed without changes
View
37 org.eclipse.swtbot.eclipse.ui/META-INF/_MANIFEST.MF_eclipse_3_5
@@ -1,37 +0,0 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: SWTBot Eclipse UI Plug-in (incubation)
-Bundle-SymbolicName: org.eclipse.swtbot.eclipse.ui;singleton:=true
-Bundle-Version: 2.0.5.qualifier
-Bundle-Activator: org.eclipse.swtbot.eclipse.ui.Activator
-Bundle-ActivationPolicy: lazy
-Bundle-Vendor: Eclipse.org - SWTBot
-Export-Package: org.eclipse.swtbot.eclipse.ui,
- org.eclipse.swtbot.eclipse.ui.launcher,
- org.eclipse.swtbot.eclipse.ui.preferences,
- org.eclipse.swtbot.eclipse.ui.project,
- org.eclipse.swtbot.eclipse.ui.wizards
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: org.eclipse.core.resources,
- org.eclipse.core.runtime,
- org.eclipse.core.runtime.jobs,
- org.eclipse.core.runtime.preferences,
- org.eclipse.debug.core,
- org.eclipse.debug.ui,
- org.eclipse.jdt.core,
- org.eclipse.jdt.junit.launcher,
- org.eclipse.jdt.launching,
- org.eclipse.jdt.ui,
- org.eclipse.jface.preference,
- org.eclipse.jface.resource,
- org.eclipse.jface.util,
- org.eclipse.jface.wizard,
- org.eclipse.osgi.util,
- org.eclipse.pde.core.plugin,
- org.eclipse.pde.ui.launcher,
- org.eclipse.swt.events,
- org.eclipse.swt.layout,
- org.eclipse.swt.widgets,
- org.eclipse.ui,
- org.eclipse.ui.plugin,
- org.osgi.framework
View
0  ...e.swtbot.eclipse.ui/_build.properties.eclipse_3_5 → org.eclipse.swtbot.eclipse.ui/build.properties
File renamed without changes
View
0  org.eclipse.swtbot.junit4_x/_classpath.junit4_5 → org.eclipse.swtbot.junit4_x/.classpath
File renamed without changes
View
6 ...pse.swtbot.junit4_x/META-INF/MANIFEST.MF_junit4_5 → org.eclipse.swtbot.junit4_x/META-INF/MANIFEST.MF
@@ -10,6 +10,6 @@ Import-Package: org.apache.log4j;version="1.2.12",
org.eclipse.swt.widgets,
org.eclipse.swtbot.swt.finder,
org.eclipse.swtbot.swt.finder.utils,
- org.junit.runner.notification;version="4.5.0",
- org.junit.runners;version="4.5.0",
- org.junit.runners.model;version="4.5.0"
+ org.junit.runner.notification;version="4.8.0",
+ org.junit.runners;version="4.8.0",
+ org.junit.runners.model;version="4.8.0"
View
0  ...clipse.swtbot.junit4_x/_build.properties.junit4_5 → org.eclipse.swtbot.junit4_x/build.properties
File renamed without changes
View
13 org.eclipse.swtbot.releng/build-conf/e35.properties
@@ -1,13 +0,0 @@
-## The location from where eclipse SDK will be downloaded in case there's none in the releng/externals directory
-## Don't add the trailing file name, the file name is automatically appended based on eclipse.sdk.archive
-## for locations of the eclipse SDKs
-## see http://download.eclipse.org/eclipse/downloads/ and http://archive.eclipse.org/eclipse/downloads/index.php
-
-#eclipse.sdk.url = http://mirrors.ibiblio.org/pub/mirrors/eclipse/eclipse/downloads/drops/R-3.5.1-200909170800
-
-eclipse.sdk.url = http://archive.eclipse.org/eclipse/downloads/drops/R-3.5-200906111540
-
-eclipse.buildId = 3.5
-eclipse.qualifier = e35
-
-update.site.base.url = http://www.eclipse.org/downloads/download.php?r=1&file=/technology/swtbot/galileo/dev-build/update-site
View
28 org.eclipse.swtbot.releng/build.xml
@@ -135,34 +135,7 @@
</sync>
</target>
- <target name="make-substitutions-4.5" if="isJunit4.5">
- <!-- make substitutions in the eclipse-ui plugin. See https://bugs.eclipse.org/bugs/show_bug.cgi?id=274083#c5 -->
- <copy file="../org.eclipse.swtbot.eclipse.ui/_build.properties.eclipse_3_5" tofile="../org.eclipse.swtbot.eclipse.ui/build.properties" overwrite="true" />
- <copy file="../org.eclipse.swtbot.eclipse.ui/META-INF/_MANIFEST.MF_eclipse_3_5" tofile="../org.eclipse.swtbot.eclipse.ui/META-INF/MANIFEST.MF" overwrite="true" />
- <copy file="../org.eclipse.swtbot.eclipse.ui/_classpath.eclipse_3_5" tofile="../org.eclipse.swtbot.eclipse.ui/.classpath" overwrite="true" />
-
- <!-- make substitutions in the junit plugin -->
- <copy file="../org.eclipse.swtbot.junit4_x/META-INF/MANIFEST.MF_junit4_5" tofile="../org.eclipse.swtbot.junit4_x/META-INF/MANIFEST.MF" overwrite="true" />
- <copy file="../org.eclipse.swtbot.junit4_x/_build.properties.junit4_5" tofile="../org.eclipse.swtbot.junit4_x/build.properties" overwrite="true" />
- <copy file="../org.eclipse.swtbot.junit4_x/_classpath.junit4_5" tofile="../org.eclipse.swtbot.junit4_x/.classpath" overwrite="true" />
- </target>
- <target name="make-substitutions-4.8" if="isJunit4.8">
- <!-- make substitutions in the eclipse-ui plugin. See https://bugs.eclipse.org/bugs/show_bug.cgi?id=274083#c5 -->
- <copy file="../org.eclipse.swtbot.eclipse.ui/META-INF/_MANIFEST.MF_eclipse_3_6" tofile="../org.eclipse.swtbot.eclipse.ui/META-INF/MANIFEST.MF" overwrite="true" />
-
- <!-- same as eclipse 3.5 -->
- <copy file="../org.eclipse.swtbot.eclipse.ui/_build.properties.eclipse_3_5" tofile="../org.eclipse.swtbot.eclipse.ui/build.properties" overwrite="true" />
- <copy file="../org.eclipse.swtbot.eclipse.ui/_classpath.eclipse_3_5" tofile="../org.eclipse.swtbot.eclipse.ui/.classpath" overwrite="true" />
-
- <!-- make substitutions in the junit plugin -->
- <copy file="../org.eclipse.swtbot.junit4_x/META-INF/MANIFEST.MF_junit4_5" tofile="../org.eclipse.swtbot.junit4_x/META-INF/MANIFEST.MF" overwrite="true" />
- <copy file="../org.eclipse.swtbot.junit4_x/_build.properties.junit4_5" tofile="../org.eclipse.swtbot.junit4_x/build.properties" overwrite="true" />
- <copy file="../org.eclipse.swtbot.junit4_x/_classpath.junit4_5" tofile="../org.eclipse.swtbot.junit4_x/.classpath" overwrite="true" />
- </target>
-
- <target name="make-substitutions" depends="guess-junit-version, make-substitutions-4.5, make-substitutions-4.8" />
-
<target name="extract-eclipse">
<condition property="setupTarget" value="setup-zip">
<contains string="${eclipse.sdk.archive}" substring=".zip" />
@@ -203,7 +176,6 @@
</unzip>
<antcall target="initialize-environment" />
- <antcall target="make-substitutions" />
</target>
<target name="printjvm">
View
22 org.eclipse.swtbot.releng/check-prerequisites.xml
@@ -67,27 +67,7 @@
<fail unless="build.developer.properties.available">Could not find the file "build.developer.properties", or host-conf/build.${hostname}.properties. Please create the file using "build.developer.properties.sample" as the starting point.</fail>
</target>
- <target name="guess-junit-version">
- <echo>Guessing plugin version of org.junit4.</echo>
- <for param="junit-version-file">
- <dirset dir="../eclipse/plugins/" includes="org.junit4_*" />
- <sequential>
- <propertyregex property="junit4-build-version" input="@{junit-version-file}" regexp="org.junit4_(.*)" select="\1" />
- </sequential>
- </for>
- <condition property="isJunit4.8">
- <contains string="${junit4-build-version}" substring="4.8" />
- </condition>
- <condition property="isJunit4.5">
- <contains string="${junit4-build-version}" substring="4.5" />
- </condition>
- <fail unless="junit4-build-version" message="Could not find org.junit4 in target eclipse" />
- <echo>Plugin version of org.junit is "${junit4-build-version}"</echo>
- <echo>isJunit4.5: ${isJunit4.5}</echo>
- <echo>isJunit4.8: ${isJunit4.8}</echo>
- </target>
-
- <target name="initialize-environment" depends="guess-junit-version, guess-pde-build-version, create-build-properties-from-template" />
+ <target name="initialize-environment" depends="guess-pde-build-version, create-build-properties-from-template" />
<delete file=".git.properties" />
<touch file=".git.properties" />
View
1  org.eclipse.swtbot.releng/make-release.rb
@@ -35,7 +35,6 @@ def self.run(args)
FileUtils.rm_rf('to-upload')
FileUtils.rm_rf('target')
- build_swtbot(35, 'galileo')
build_swtbot(36, 'helios')
build_swtbot(37, 'indigo')
end
Please sign in to comment.
Something went wrong with that request. Please try again.