Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Fetching contributors…

Cannot retrieve contributors at this time

76 lines (59 sloc) 3.575 kb
<?xml version="1.0" encoding="UTF-8" ?>
<project name="testsuite" default="run" basedir=".">
<property name="eclipse-home" value="${basedir}\..\.." />
<property name="plugin-under-test" value="org.eclipse.swtbot.eclipse.finder" />
<property name="plugin-name" value="org.eclipse.swtbot.eclipse.finder.test" />
<property name="library-file" value="${eclipse-home}/plugins/org.eclipse.swtbot.eclipse.junit4.headless_${all.buildId}/library.xml"/>
<property name="build.instrumentation.reports.dir" value="${results.dir}/${plugin-name}/coverage/html" />
<property name="build.instrumentation.reports.xml.dir" value="${results.dir}/${plugin-name}/coverage/xml" />
<property name="cobertura.data.file" value="${basedir}/${plugin-name}.ser" />
<target name="init">
<tstamp />
<delete>
<fileset dir="${eclipse-home}" includes="org*.xml" />
</delete>
</target>
<path id="cobertura.classpath">
<fileset dir="${build.base}/../externals/libs/cobertura-1.9.4.1">
<include name="cobertura.jar" />
<include name="lib/**/*.jar" />
</fileset>
</path>
<taskdef classpathref="cobertura.classpath" resource="tasks.properties" />
<target name="instrument">
<delete file="${cobertura.data.file}" />
<cobertura-instrument datafile="${cobertura.data.file}">
<fileset dir="${eclipse-home}/plugins">
<include name="${plugin-under-test}_${all.buildId}.jar" />
</fileset>
</cobertura-instrument>
</target>
<target name="suite">
<condition property="jvmOption" value="-XstartOnFirstThread -Dorg.eclipse.swt.internal.carbon.smallFonts -Dnet.sourceforge.cobertura.datafile=${cobertura.data.file} -Xbootclasspath/p:${build.base}/../externals/libs/cobertura-1.9.4.1/cobertura.jar">
<os family="mac" />
</condition>
<property name="jvmOption" value="-Dnet.sourceforge.cobertura.datafile=${cobertura.data.file} -Xbootclasspath/p:${build.base}/../externals/libs/cobertura-1.9.4.1/cobertura.jar" />
<property name="temp-workspace" value="workspace" />
<delete dir="${temp-workspace}" quiet="true" />
<!-- remove junit3 fragment -->
<delete dir="${eclipse-home}/plugins/org.eclipse.swtbot.eclipse.junit3.headless_${all.buildId}" />
<delete dir="${eclipse-home}/plugins" includes="org.eclipse.swtbot.ant.optional.junit3_${all.buildId}.jar"/>
<ant target="swtbot-test" antfile="${library-file}" dir="${eclipse-home}">
<property name="data-dir" value="${temp-workspace}" />
<property name="testApplication" value="org.eclipse.ui.ide.workbench" />
<property name="plugin-name" value="${plugin-name}" />
<property name="classname" value="org.eclipse.swtbot.eclipse.finder.AllTests" />
<property name="vmargs" value=" -Xms128M -Xmx368M -XX:MaxPermSize=256M ${jvmOption} ${extra.jvm.options}" />
</ant>
</target>
<target name="test-coverage">
<cobertura-report format="html" destdir="${build.instrumentation.reports.dir}" srcdir="${build.base}/plugins/${plugin-under-test}/src" datafile="${cobertura.data.file}" />
<cobertura-report format="xml" destdir="${build.instrumentation.reports.xml.dir}" srcdir="${build.base}/plugins/${plugin-under-test}/src" datafile="${cobertura.data.file}" />
</target>
<target name="run" depends="init, instrument, suite, test-coverage">
<ant target="collect" antfile="${library-file}" dir="${eclipse-home}">
<property name="includes" value="*.xml" />
<property name="output-file" value="${plugin-name}.xml" />
</ant>
</target>
</project>
Jump to Line
Something went wrong with that request. Please try again.