Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Merge branch 'master' of github.com:kete/tiny_mce into experimental

  • Loading branch information...
commit 5ede17367bfa7c4cdca9a96b544c2a58d3e23a94 2 parents 2677c11 + 3350f8b
Kieran Pilkington authored
View
0  CHANGELOG_PLUGIN → CHANGELOG_PLUGIN.rdoc
File renamed without changes
View
12 DEV_UPGRADE_NOTES
@@ -1,12 +0,0 @@
----------------------------------
-How to update the bundled TinyMCE
----------------------------------
-
-1) Download TinyMCE, and extract it to your Desktop
-2) Delete the copy of TinyMCE in the plugin at lib/tiny_mce/assets/tiny_mce (this ensures old/removed files are deleted)
-3) Copy the source files of TinyMCE (not documentation) to lib/tiny_mce/assets/tiny_mce
-4) Update the CHANGELOG_PLUGIN to say what you upgraded from, what you upgraded to, and your name
-5) Update CHANGELOG_TINYMCE (download and overwrite the file with http://tinymce.moxiecode.com/js/tinymce/changelog.txt)
-6) Update the 'Bundled TinyMCE version' value at the bottom of README.rdoc
-7) Update lib/tiny_mce/valid_tinymce_options.yml with any new options, or remove old ones, as described in the tinymce changelog
-8) Commit, push, and send pull request to http://github.com/kete/tiny_mce
View
10 DEV_UPGRADE_NOTES.rdoc
@@ -0,0 +1,10 @@
+= Updating the bundled TinyMCE
+
+1. Download the new TinyMCE tarball and extract it to your Desktop (or other easily accessible location)
+2. Delete the copy of TinyMCE in the plugin at lib/tiny_mce/assets/tiny_mce (this ensures old/removed files are deleted)
+3. Copy the source files of TinyMCE (not the documentation) to lib/tiny_mce/assets/tiny_mce (so in that folder you should have a tiny_mce.js file)
+4. Update the CHANGELOG_PLUGIN.rdoc to say what you upgraded from, what you upgraded to, and your name
+5. Update CHANGELOG_TINYMCE (simply download and overwrite the contents with that of http://tinymce.moxiecode.com/js/tinymce/changelog.txt)
+6. Update the 'Bundled TinyMCE version' value at the bottom of README.rdoc
+7. Update lib/tiny_mce/valid_tinymce_options.yml with any new options, or remove old ones, as described in the tinymce changelog
+8. Commit, push, and send pull request to http://github.com/kete/tiny_mce
View
4 Rakefile
@@ -10,8 +10,8 @@ begin
gem.description = %Q{Gem that allows easy implementation of the TinyMCE editor into your applications.}
gem.email = 'kieran@katipo.co.nz'
gem.homepage = 'http://github.com/kete/tiny_mce'
- gem.authors = ['Blake Watters', 'Kieran Pilkington', 'Alexander Semyonov']
- gem.extra_rdoc_files = ['README.rdoc', 'SPELLCHECKING_PLUGIN.rdoc']
+ gem.authors = ['Blake Watters', 'Kieran Pilkington', 'Sergio Cambra', 'Alexander Semyonov']
+ gem.extra_rdoc_files = ['README.rdoc', 'SPELLCHECKING_PLUGIN.rdoc', 'CHANGELOG_PLUGIN.rdoc', 'DEV_UPGRADE_NOTES.rdoc']
gem.rdoc_options << '--exclude=lib/tiny_mce/assets'
# gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
end
View
4 lib/tiny_mce/helpers.rb
@@ -25,7 +25,7 @@ def raw_tiny_mce_init(options = {}, raw_options = '')
unless options['plugins'].nil?
raise TinyMCEInvalidOptionType.new("Invalid value of type #{options['plugins'].class} passed for TinyMCE option plugins") unless options['plugins'].kind_of?(Array)
-
+
# Append the plugins we have enabled for this field to the OptionsValidator
TinyMCE::OptionValidator.plugins += options['plugins']
end
@@ -71,7 +71,7 @@ def tiny_mce_init_if_needed(options = {}, raw_options = '')
# Form a JS include tag for the TinyMCE JS src for inclusion in the <head>
def include_tiny_mce_js
- javascript_include_tag (Rails.env.development? ? "tiny_mce/tiny_mce_src" : "tiny_mce/tiny_mce")
+ javascript_include_tag (Rails.env == 'development' ? "tiny_mce/tiny_mce_src" : "tiny_mce/tiny_mce")
end
# Form a JS include tag for the TinyMCE JS src for inclusion in the <head>
# (only if tiny mce is actually being used)
View
10 tiny_mce.gemspec
@@ -8,19 +8,21 @@ Gem::Specification.new do |s|
s.version = "0.1.0"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Blake Watters", "Kieran Pilkington", "Alexander Semyonov"]
+ s.authors = ["Blake Watters", "Kieran Pilkington", "Sergio Cambra", "Alexander Semyonov"]
s.date = %q{2009-09-17}
s.description = %q{Gem that allows easy implementation of the TinyMCE editor into your applications.}
s.email = %q{kieran@katipo.co.nz}
s.extra_rdoc_files = [
- "README.rdoc",
+ "CHANGELOG_PLUGIN.rdoc",
+ "DEV_UPGRADE_NOTES.rdoc",
+ "README.rdoc",
"SPELLCHECKING_PLUGIN.rdoc"
]
s.files = [
".gitignore",
- "CHANGELOG_PLUGIN",
+ "CHANGELOG_PLUGIN.rdoc",
"CHANGELOG_TINYMCE",
- "DEV_UPGRADE_NOTES",
+ "DEV_UPGRADE_NOTES.rdoc",
"README.rdoc",
"Rakefile",
"SPELLCHECKING_PLUGIN.rdoc",
Please sign in to comment.
Something went wrong with that request. Please try again.