Announcing App::Midgen v0.22

BOWTIE edited this page May 16, 2013 · 1 revision

Announcing App::Midgen v0.24

So what's new?

  • Switched output format type from build to mb
  • Extract more from t/ and xt/ directories ** Find modules in Test::Requires blocks ** Find modules in use_ok BEGIN blocks
  • Supports suggests in on_test in cpanfile

###switched output format type from build to mb

'midgen -f mb'

thanks for the kick azawawi++

###Extract more from t/ and xt/ directories

####Find modules in Test::Requires blocks

Examples

use Test::Requires { 'Test::Pod' => 1.46 };
use Test::Requires { 'Test::Extra' => 1.46 };
use Test::Requires qw[MIME::Types];
use Test::Requires qw(IO::Handle::Util LWP::Protocol::http10);
use Test::Requires {
  "Test::Test1" => '1.01',
  'Test::Test2' => 2.02,
 };

####Find modules in use_ok BEGIN blocks

Examples

BEGIN {
  use_ok( 'Term::ReadKey', '2.30' );
  use_ok( 'Term::ReadLine', '1.10' );
  use_ok( 'Fred::BloggsOne', '1.01' );
  use_ok( "Fred::BloggsTwo", "2.02" );
  use_ok( 'Fred::BloggsThree', 3.03 );
}

###Supports suggests in on_test in cpanfile

~/GitHub/Plack$ midgen -lf cpanfile

on test => sub {
	requires 'AnyEvent',       '7.04';
	requires 'Data::Dumper',   '2.145';
	requires 'DooBar',         '!mcpan';
	requires 'Encode',         '2.51';
	requires 'File::Path',     '2.09';
	requires 'File::Temp',     '0.2301';
	requires 'HTTP::Cookies',  '6.01';
	requires 'HTTP::Error',    '!mcpan';
	requires 'IO::File',       '1.25';
	requires 'IO::Socket',     '1.25';
	requires 'SomeModule',     '!mcpan';
	requires 'Test::Requires', '0.06';

	suggests 'Authen::Simple::Passwd', '0.6';
	suggests 'FCGI::ProcManager',      '0.24';
	suggests 'HTTP::Request::AsCGI',   '1.2';
	suggests 'IO::Handle::Util',       '0.01';
	suggests 'LWP::Protocol::http10',  '6.03';
	suggests 'Log::Dispatch',          '2.39';
	suggests 'Log::Dispatch::Array',   '1.001';
	suggests 'MIME::Types',            '1.38';
};