Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Fix Travis CI builds (the specs fail, due to clone --depth=50) #51

Merged
merged 2 commits into from

1 participant

@kevinjalbert

The specs depend on the git log by specifying a specific time range.
Travis CI will limit the git clone to a depth of 50 commits, thus this
causes some problems with our specs. An initial fix is to extend the
depth on Travis CI.

added some commits
@kevinjalbert Fix Travis CI builds (the specs fail, due to clone --depth=50)
The specs depend on the `git log` by specifying a specific time range.
Travis CI will limit the git clone to a depth of 50 commits, thus this
causes some problems with our specs. An initial fix is to extend the
depth on Travis CI.
ec5f261
@kevinjalbert Remove version dependancies on charlock_holmes c47886a
@kevinjalbert

Seems to be working fine on the PR. Going to merge this and hopefully it keeps working on master.

@kevinjalbert kevinjalbert merged commit d63f9f7 into master
@kevinjalbert kevinjalbert deleted the fix-travis-builds branch
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Mar 30, 2013
  1. Fix Travis CI builds (the specs fail, due to clone --depth=50)

    authored
    The specs depend on the `git log` by specifying a specific time range.
    Travis CI will limit the git clone to a depth of 50 commits, thus this
    causes some problems with our specs. An initial fix is to extend the
    depth on Travis CI.
This page is out of date. Refresh to see the latest.
Showing with 5 additions and 3 deletions.
  1. +2 −0  .travis.yml
  2. +1 −1  Gemfile
  3. +2 −2 git_statistics.gemspec
View
2  .travis.yml
@@ -13,4 +13,6 @@ before_install:
notifications:
email: false
+before_script: git pull -q --depth=1000000
+
script: bundle exec rspec spec
View
2  Gemfile
@@ -1,7 +1,7 @@
source 'https://rubygems.org'
gemspec
-gem "charlock_holmes", "0.6.9.1"
+gem "charlock_holmes"
group :test do
gem "simplecov"
View
4 git_statistics.gemspec
@@ -17,8 +17,8 @@ Gem::Specification.new do |gem|
gem.required_ruby_version = '>= 1.9.1'
gem.add_dependency('json')
- gem.add_dependency('grit', '2.5.0')
- gem.add_dependency('github-linguist', '2.4.0')
+ gem.add_dependency('grit')
+ gem.add_dependency('github-linguist')
gem.add_development_dependency "rspec", "~> 2.12.0"
gem.add_development_dependency "rake"
Something went wrong with that request. Please try again.