Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Fix Travis CI builds (the specs fail, due to clone --depth=50) #51

Merged
merged 2 commits into from over 1 year ago

1 participant

Kevin Jalbert
Kevin Jalbert
Owner

The specs depend on the git log by specifying a specific time range.
Travis CI will limit the git clone to a depth of 50 commits, thus this
causes some problems with our specs. An initial fix is to extend the
depth on Travis CI.

added some commits
Kevin Jalbert Fix Travis CI builds (the specs fail, due to clone --depth=50)
The specs depend on the `git log` by specifying a specific time range.
Travis CI will limit the git clone to a depth of 50 commits, thus this
causes some problems with our specs. An initial fix is to extend the
depth on Travis CI.
ec5f261
Kevin Jalbert Remove version dependancies on charlock_holmes c47886a
Kevin Jalbert
Owner

Seems to be working fine on the PR. Going to merge this and hopefully it keeps working on master.

Kevin Jalbert kevinjalbert merged commit d63f9f7 into from
Kevin Jalbert kevinjalbert deleted the branch
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Showing 2 unique commits by 1 author.

Mar 30, 2013
Kevin Jalbert Fix Travis CI builds (the specs fail, due to clone --depth=50)
The specs depend on the `git log` by specifying a specific time range.
Travis CI will limit the git clone to a depth of 50 commits, thus this
causes some problems with our specs. An initial fix is to extend the
depth on Travis CI.
ec5f261
Kevin Jalbert Remove version dependancies on charlock_holmes c47886a
This page is out of date. Refresh to see the latest.

Showing 3 changed files with 5 additions and 3 deletions. Show diff stats Hide diff stats

  1. +2 0  .travis.yml
  2. +1 1  Gemfile
  3. +2 2 git_statistics.gemspec
2  .travis.yml
@@ -13,4 +13,6 @@ before_install:
13 13 notifications:
14 14 email: false
15 15
  16 +before_script: git pull -q --depth=1000000
  17 +
16 18 script: bundle exec rspec spec
2  Gemfile
... ... @@ -1,7 +1,7 @@
1 1 source 'https://rubygems.org'
2 2 gemspec
3 3
4   -gem "charlock_holmes", "0.6.9.1"
  4 +gem "charlock_holmes"
5 5
6 6 group :test do
7 7 gem "simplecov"
4 git_statistics.gemspec
@@ -17,8 +17,8 @@ Gem::Specification.new do |gem|
17 17 gem.required_ruby_version = '>= 1.9.1'
18 18
19 19 gem.add_dependency('json')
20   - gem.add_dependency('grit', '2.5.0')
21   - gem.add_dependency('github-linguist', '2.4.0')
  20 + gem.add_dependency('grit')
  21 + gem.add_dependency('github-linguist')
22 22
23 23 gem.add_development_dependency "rspec", "~> 2.12.0"
24 24 gem.add_development_dependency "rake"

Tip: You can add notes to lines in a file. Hover to the left of a line to make a note

Something went wrong with that request. Please try again.