Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
A multi-protocol curses IM client.
C Perl Shell

This branch is 11 commits behind barnowl:master

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
compat
doc
examples
libfaim
m4
perl
scripts
t
.gitignore
.mailmap
.travis.yml
AUTHORS
COPYING
ChangeLog
Makefile.am
README
aim.c
autogen.sh
barnowl-wrapper.in
buddy.c
buddylist.c
closures.c
cmd.c
codelist.pl
commands.c
configure.ac
context.c
dict.c
editcontext.c
editwin.c
errqueue.c
filter.c
filterelement.c
filterproc.c
filterproc.h
fmtext.c
functions.c
global.c
help.c
history.c
keybinding.c
keymap.c
keypress.c
keys.c
logging.c
mainpanel.c
mainwin.c
marshal_types
message.c
messagelist.c
msgwin.c
owl.c
owl.h
owl_perl.h
pair.c
perlconfig.c
perlglue.xs
popexec.c
popwin.c
regex.c
runtests.sh
select.c
sepbar.c
signal.c
stubgen.pl
style.c
tester.c
text.c
typemap
util.c
variable.c
view.c
viewwin.c
wcwidth.c
window.c
window.h
windowcb.c
zbuddylist.c
zcrypt.c
zephyr.c
zwrite.c

README

BarnOwl - owl, with more ponies

Source is freely available from http://github.com/barnowl/barnowl/

Based on owl 2.1.11, by James Kretchmar (http://www.ktools.org)

Notes:
-----
This project's perl/modules/ contains the lib directories from the
following CPAN modules:

Facebook::Graph
Net::Jabber
Net::XMPP
XML::Stream

Some have been modified slightly for the needs of this project.

BarnOwl currently requires the following perl modules off of CPAN:

AnyEvent
Class::Accessor
ExtUtils::Depends
Glib
Module::Install
PAR

(Note that these are all available as Debian packages)
We plan to soon add targets to the Makefile to check for and install
these for you.

The Facebook module requires:

Any::Moose
AnyEvent::HTTP
DateTime
DateTime::Format::Strptime
JSON
MIME::Base64::URLSafe
Ouch
URI
URI::Encode

The IRC module requires:

AnyEvent::IRC

The Jabber module requires:

Net::DNS
Authen::SASL::Perl
IO::Socket::SSL
Digest::SHA

The Twitter module requires:

HTML::Entities
Net::Twitter::Lite

The WordWrap module requires:

Text::Autoformat
Something went wrong with that request. Please try again.