Files to build due to dependency on older version of transformers #1

Closed
afcowie opened this Issue Nov 17, 2012 · 2 comments

Projects

None yet

2 participants

@afcowie
afcowie commented Nov 17, 2012

It would appear scope requires on an old version of transformers and mtl. That's unfortunate, as it means on a GHC 7.4 system with (for instance, hedis) installed, I can't bring in scope.

Is this just a case of needing a quick bump or is this likely to be a hard dependency?

AfC

transformers-base-0.4.1 (reinstall) changes: transformers-0.3.0.0 -> 0.2.2.0
iteratee-compress-0.3.2.0 (reinstall) changes: mtl-2.1.2 -> 2.0.1.0
zoom-cache-1.2.1.4 (reinstall) changes: MonadCatchIO-transformers-0.3.0.0 ->
0.2.2.3, mtl-2.1.2 -> 2.0.1.0, transformers-0.3.0.0 -> 0.2.2.
iteratee-0.8.9.4 (reinstall) changes: MonadCatchIO-transformers-0.3.0.0 ->
0.2.2.3, monad-control-0.3.1.3 -> 0.3.1.4, transformers-0.3.0.0 -> 0.2.2.0
cabal: The following packages are likely to be broken by the reinstalls:
resourcet-0.3.2.2
pool-conduit-0.1.0.2
persistent-1.0.1
scion-browser-0.2.10
persistent-template-1.0.0
persistent-sqlite-1.0.0
monad-logger-0.2.0
conduit-0.5.2.7
attoparsec-conduit-0.5.0.2
conduit-0.5.2.3
blaze-builder-conduit-0.5.0
resource-pool-0.2.1.0
hedis-0.5
monad-control-0.3.1.3
lifted-base-0.1.1

@kfish
Owner
kfish commented Nov 19, 2012

I've just uploaded new versions with version bumps of zoom-cache, scope, and scope-cairo; could you please check if they build for you?

@afcowie
afcowie commented Nov 19, 2012

Good to go, thanks!

AfC

@afcowie afcowie closed this Nov 19, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment