New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Language preferences load in wrong order #1064

Open
jboothe opened this Issue Nov 2, 2017 · 3 comments

Comments

Projects
None yet
3 participants
@jboothe

jboothe commented Nov 2, 2017

Expect to see all terms in English when setting language preference to en.

screen shot 2017-11-02 at 5 40 59 pm

Actual see a mix of English and non-English terms in the UI.

screen shot 2017-11-02 at 5 40 04 pm

Initially this happened when (ironically) I changed the theme to Nordic. From that point on I have not been able to get back to English.

Reproducable on demo.kimai.org? yes

@kevinpapst kevinpapst changed the title from Demo App Partially English to Language preferences load in wrong order Dec 16, 2017

@kevinpapst

This comment has been minimized.

Show comment
Hide comment
@kevinpapst

kevinpapst Dec 16, 2017

Member

Thanks for the finding!
I guess I could reproduce it.
First I tried to switch the user preference: first change to nordic, than the user language to es than back to en. Everything worked fine.
But there is a second language setting, which is in the "Advanced" section of the admin panel. That currently seems to override the users setting, which is simply wrong.
The user language preference should always overrule the system setting.

Member

kevinpapst commented Dec 16, 2017

Thanks for the finding!
I guess I could reproduce it.
First I tried to switch the user preference: first change to nordic, than the user language to es than back to en. Everything worked fine.
But there is a second language setting, which is in the "Advanced" section of the admin panel. That currently seems to override the users setting, which is simply wrong.
The user language preference should always overrule the system setting.

@logological

This comment has been minimized.

Show comment
Hide comment
@logological

logological Jan 2, 2018

The problem affects the Demo installation. Currently the demo UI shows a mixture of Russian and English. By fumbling around, I was able to locate what looks like a language setting and change it to English, but it had no effect on the UI labels. This makes it impossible for me (and everyone else who doesn't speak Russian) to use the demo.

logological commented Jan 2, 2018

The problem affects the Demo installation. Currently the demo UI shows a mixture of Russian and English. By fumbling around, I was able to locate what looks like a language setting and change it to English, but it had no effect on the UI labels. This makes it impossible for me (and everyone else who doesn't speak Russian) to use the demo.

@kevinpapst

This comment has been minimized.

Show comment
Hide comment
@kevinpapst

kevinpapst Jan 2, 2018

Member

I switched the demo back to english @logological

Member

kevinpapst commented Jan 2, 2018

I switched the demo back to english @logological

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment