New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Date Entry Problem (date is disappeared) #1171

Open
Summer-scalefree opened this Issue May 14, 2018 · 6 comments

Comments

Projects
None yet
3 participants
@Summer-scalefree

Summer-scalefree commented May 14, 2018

A date is supposed to be added

Once I choose the date I want to add, it is disappeared from the input box. and when I click the date to tired to add again, doesn't work.
Only from the calendar from the Add floater

Steps to reproduce

Reproducable on demo.kimai.org? [yes|no]

Kimai version [for example: dev 1.1.0.1389|github master|github develop] v1.2.2.1394

Relevant log entries from log file (debug tab or temporary/logfile.txt)

@simonschaufi

This comment has been minimized.

Member

simonschaufi commented May 14, 2018

Hi. I don't understand the problem. Can you verify it on the kimai demo? Which browser do you use?

@Summer-scalefree

This comment has been minimized.

Summer-scalefree commented May 14, 2018

@edgetek

This comment has been minimized.

edgetek commented May 14, 2018

Not sure the date is disappearing, but the date functionality is a little off.
I am using US date format mm/dd/yyyy but it prefers the European date format dd/mm/yyyy.
It work if you input the data on that day, but if you try to put in time that had happened the day before or any day in the past using the calendar GUI, it will convert back to European format.
I usually just manually type in the date now, I am using v1.2.2.1394 now just upgraded today, but this issue was there in the previous version as well.
Today, date not selected from GUI.
image 4902

Date selected from GUI
image 4906

@simonschaufi

This comment has been minimized.

Member

simonschaufi commented May 15, 2018

I think #1121 addresses exactly your problem. Can anyone help in reviewing this pull request?

@edgetek

This comment has been minimized.

edgetek commented May 31, 2018

Thank you, I just saw the update to 1.3, but i wanted to let you know that i think the releases are mixed up, when you go to download stable, it is downloading kimai-kimai-1.3.1-8-g47f4050 and you go to the dev release it is showing up as kimai_1.3.1 no complaints just an FYI and thank you!

@simonschaufi

This comment has been minimized.

Member

simonschaufi commented May 31, 2018

Don't mixup the official release with the zip file of master branch! They are very different. Stable is for developers only (just a zip file of master branch from the github sources) while the release contains all composer packages as well. They are excluded in the "stable" release and you need fetch them yourself.

@kimai kimai deleted a comment from edgetek May 31, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment