New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Installation ubuntu 18.04 - with workaround :D #1242

Open
aluvare opened this Issue Jul 10, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@aluvare

aluvare commented Jul 10, 2018

The library python-imaging was changed in ubuntu 18.04 to python-pil.

Kimchi dependencies in ubuntu 18.04:

apt install python-pil python-configobj novnc python-libvirt libvirt-bin nfs-common qemu-kvm python-parted python-ethtool python-ipaddr python-guestfs libguestfs-tools spice-html5 python-magic python-paramiko

Patch:

ar x kimchi-2.5.0-0.noarch.deb
tar -zxvf control.tar.gz
sed -i 's/python-imaging/python-pil/g' control
tar c Makefile Makefile.am Makefile.in control control.in | gzip -c > control.tar.gz
ar rcs kimchi-2.5.0-0.noarch_patched.deb debian-binary control.tar.gz data.tar.xz

And after that:

dpkg -i kimchi-2.5.0-0.noarch_patched.deb
@hotnikq

This comment has been minimized.

Show comment
Hide comment
@hotnikq

hotnikq Jul 20, 2018

kimchi : Depende: wok (>= 2.1.0) mas não é instalável
Depende: python-jsonschema (>= 1.3.0) mas não será instalado
Depende: python-psutil (>= 0.6.0) mas não será instalado
Depende: sosreport mas não será instalado
Depende: python-lxml mas não será instalado

hotnikq commented Jul 20, 2018

kimchi : Depende: wok (>= 2.1.0) mas não é instalável
Depende: python-jsonschema (>= 1.3.0) mas não será instalado
Depende: python-psutil (>= 0.6.0) mas não será instalado
Depende: sosreport mas não será instalado
Depende: python-lxml mas não será instalado

@hotnikq

This comment has been minimized.

Show comment
Hide comment
@hotnikq

hotnikq Jul 20, 2018

I will clear install ubuntu and try again soon,
my kvm server have gpu passthrough
with nvidia Nvs card for host with Nouveau blacklist "hard to do"
it will take some weeks.

hotnikq commented Jul 20, 2018

I will clear install ubuntu and try again soon,
my kvm server have gpu passthrough
with nvidia Nvs card for host with Nouveau blacklist "hard to do"
it will take some weeks.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment