Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Kimchi won't install on Kubuntu 15.10; it hangs #821

Closed
JesseTG opened this issue Jan 7, 2016 · 14 comments
Closed

Kimchi won't install on Kubuntu 15.10; it hangs #821

JesseTG opened this issue Jan 7, 2016 · 14 comments

Comments

@JesseTG
Copy link

@JesseTG JesseTG commented Jan 7, 2016

When I try to install Kimchi from the official repos on Kubuntu 15.10 64-bit, apt-get starts to install it...then nothing. No output, it just hangs. I think the installer might have hit an infinite loop or a deadlock or something. I had to stop installation, but now even dpkg can't uninstall it, so I can't install or remove any packages from my system until this is fixed!

@tbludau
Copy link

@tbludau tbludau commented Jan 9, 2016

I've the same problem here. Found out, that this process was hanging: /bin/sh /var/lib/dpkg/info/kimchi.postinst configure
After some research i saw, that the /lib/systemd/system/kimchi.service file is wrong in the ubuntu package.
This entry in the file is right:
Requires=libvirt-bin.service
After=libvirt-bin.service

instead of this wrong configuration:
Requires=libvirtd.service
After=libvirtd.service

After changing this and restart the kimchi service with
service kimchi restart

the package installation in another window finished the installation

@tbludau
Copy link

@tbludau tbludau commented Jan 9, 2016

And: /etc/pam.d/kichmi is wrong. instead of libvirt the group should be libvirtd
auth sufficient pam_succeed_if.so user ingroup libvirtd
instead of
auth sufficient pam_succeed_if.so user ingroup libvirt

@computergeek125
Copy link

@computergeek125 computergeek125 commented Feb 8, 2016

I can confirm that @RockoPB 's workaround with the systemd script works in Ubuntu 15.10 Desktop (Linux 4.2.0-27-generic). Thanks for the tip!

@alinefm
Copy link
Member

@alinefm alinefm commented Mar 9, 2016

Closing based on last comments.

@alinefm alinefm closed this Mar 9, 2016
@alinefm
Copy link
Member

@alinefm alinefm commented Mar 9, 2016

The /lib/systemd/system/kimchi.service file was already ficed by 2.1 release according to #816

@computergeek125
Copy link

@computergeek125 computergeek125 commented Mar 9, 2016

So that would explain it: Ubuntu is using a version of 1.5.0 in their repo (1.5.0-0ubuntu1)

@philled
Copy link

@philled philled commented Jun 7, 2016

I installed using "sudo apt-get install kimchi" on a new Ubuntu 16.04 server and made the changes to /lib/systemd/system/kimchi.service and /etc/pam.d/kichmi as recommended. But when I try to browse to kimchi from a remote PC no page comes up. I'm trying these URLs:

http://192.168.0.102:8000/
http://192.168.0.102:8001/
http://192.168.0.102:8010/
http2://192.168.0.102:8000/
http2://192.168.0.102:8001/
http2://192.168.0.102:8010/

I can get a telnet connection on the localhost:

telnet localhost 8010
Trying ::1...
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.

But not when I do it try it from another machine.

In /etc/kimich.conf I have:

[server]
# Start the proxy service?
#run_proxy = off

# Hostname or IP address to listen on
###host = 0.0.0.0
host = 192.168.0.102

# Port to listen on
###port = 8000
port = 8000

# If present, start an SSL-enabled server on the given port
###ssl_port = 8001
ssl_port = 8001

# Cherrypy server port
###cherrypy_port = 8010
cherrypy_port = 8010

etc...

Any suggestions as to what may be wrong? Do I have to do something to nginx conf?

@vmorris
Copy link

@vmorris vmorris commented Oct 22, 2016

This is still a problem in Xenial 16.04.1 -- please get this up into the ubuntu repos 👍

@davidzengxhsh
Copy link

@davidzengxhsh davidzengxhsh commented Nov 17, 2016

The last step is still hang with Ubuntu 16.10. I even can NOT get out with Ctrl-C.

@Trolldemorted
Copy link

@Trolldemorted Trolldemorted commented Dec 7, 2016

@alinefm we are running a brand-new ubuntu 16.10 apt-get install kimchi freezes. could you re-open this issue?

@matjahs
Copy link

@matjahs matjahs commented Jun 7, 2017

Also tried to install on a fresh ubuntu server 16.04 install. First did an update/upgrade cycle followed by sudo apt-get install kimchi, hangs on Setting up kimchi (1.5.0-0ubuntu1) ..., I can see the command /bin/sh /var/lib/dpkg/info/kimchi.postinst configure running with ps. This is still exactly the same problem as at the beginning of this thread but its still in the ubuntu repos

@alinefm
Copy link
Member

@alinefm alinefm commented Jun 7, 2017

Hi @Raven283

Please, do not install Kimchi using apt. The package available there is too old (it is 1.5.0 version and latest Kimchi release is 2.4.0) and does not work due several issues.

To install Kimchi, get the packages available at http://kimchi-project.github.io/kimchi/downloads/

@Trolldemorted
Copy link

@Trolldemorted Trolldemorted commented Jun 7, 2017

You probably should remove that package, if possible.

@alinefm
Copy link
Member

@alinefm alinefm commented Jun 7, 2017

@Trolldemorted There is an open request against Ubuntu community to do that.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
9 participants