Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master
Fetching contributors…

Cannot retrieve contributors at this time

file 94 lines (90 sloc) 3.902 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94
# Generated by jeweler
# DO NOT EDIT THIS FILE DIRECTLY
# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-

Gem::Specification.new do |s|
  s.name = "sunspot_index_queue"
  s.version = "1.1.4"

  s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
  s.authors = ["Brian Durand"]
  s.date = "2012-06-19"
  s.description = "This gem provides asynchronous indexing to Solr for the sunspot gem. It uses a pluggable model for the backing queue and provides support for ActiveRecord, DataMapper, and MongoDB out of the box."
  s.email = "brian@embellishedvisions.com"
  s.extra_rdoc_files = [
    "README.rdoc"
  ]
  s.files = [
    ".travis.yml",
    "CHANGE_LOG.txt",
    "MIT_LICENSE",
    "README.rdoc",
    "Rakefile",
    "VERSION",
    "lib/sunspot/index_queue.rb",
    "lib/sunspot/index_queue/batch.rb",
    "lib/sunspot/index_queue/entry.rb",
    "lib/sunspot/index_queue/entry/active_record_impl.rb",
    "lib/sunspot/index_queue/entry/data_mapper_impl.rb",
    "lib/sunspot/index_queue/entry/mongo_impl.rb",
    "lib/sunspot/index_queue/entry/redis_impl.rb",
    "lib/sunspot/index_queue/session_proxy.rb",
    "lib/sunspot_index_queue.rb",
    "spec/active_record_impl_spec.rb",
    "spec/batch_spec.rb",
    "spec/data_mapper_impl_spec.rb",
    "spec/entry_impl_examples.rb",
    "spec/entry_spec.rb",
    "spec/index_queue_spec.rb",
    "spec/integration_spec.rb",
    "spec/mongo_impl_spec.rb",
    "spec/redis_impl_spec.rb",
    "spec/session_proxy_spec.rb",
    "spec/spec_helper.rb",
    "sunspot_index_queue.gemspec"
  ]
  s.homepage = "http://github.com/bdurand/sunspot_index_queue"
  s.rdoc_options = ["--charset=UTF-8", "--main", "README.rdoc", "MIT_LICENSE"]
  s.require_paths = ["lib"]
  s.rubygems_version = "1.8.11"
  s.summary = "Asynchronous Solr indexing support for the sunspot gem with an emphasis on reliablity and throughput."

  if s.respond_to? :specification_version then
    s.specification_version = 3

    if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
      s.add_runtime_dependency(%q<sunspot>, [">= 1.1.0"])
      s.add_development_dependency(%q<sqlite3>, [">= 0"])
      s.add_development_dependency(%q<activerecord>, [">= 2.2"])
      s.add_development_dependency(%q<dm-core>, [">= 1.0.0"])
      s.add_development_dependency(%q<dm-aggregates>, [">= 1.0.0"])
      s.add_development_dependency(%q<dm-migrations>, [">= 1.0.0"])
      s.add_development_dependency(%q<dm-sqlite-adapter>, [">= 1.0.0"])
      s.add_development_dependency(%q<mongo>, [">= 0"])
      s.add_development_dependency(%q<redis>, [">= 0"])
      s.add_development_dependency(%q<rspec>, [">= 2.0.0"])
      s.add_development_dependency(%q<jeweler>, [">= 0"])
    else
      s.add_dependency(%q<sunspot>, [">= 1.1.0"])
      s.add_dependency(%q<sqlite3>, [">= 0"])
      s.add_dependency(%q<activerecord>, [">= 2.2"])
      s.add_dependency(%q<dm-core>, [">= 1.0.0"])
      s.add_dependency(%q<dm-aggregates>, [">= 1.0.0"])
      s.add_dependency(%q<dm-migrations>, [">= 1.0.0"])
      s.add_dependency(%q<dm-sqlite-adapter>, [">= 1.0.0"])
      s.add_dependency(%q<mongo>, [">= 0"])
      s.add_dependency(%q<redis>, [">= 0"])
      s.add_dependency(%q<rspec>, [">= 2.0.0"])
      s.add_dependency(%q<jeweler>, [">= 0"])
    end
  else
    s.add_dependency(%q<sunspot>, [">= 1.1.0"])
    s.add_dependency(%q<sqlite3>, [">= 0"])
    s.add_dependency(%q<activerecord>, [">= 2.2"])
    s.add_dependency(%q<dm-core>, [">= 1.0.0"])
    s.add_dependency(%q<dm-aggregates>, [">= 1.0.0"])
    s.add_dependency(%q<dm-migrations>, [">= 1.0.0"])
    s.add_dependency(%q<dm-sqlite-adapter>, [">= 1.0.0"])
    s.add_dependency(%q<mongo>, [">= 0"])
    s.add_dependency(%q<redis>, [">= 0"])
    s.add_dependency(%q<rspec>, [">= 2.0.0"])
    s.add_dependency(%q<jeweler>, [">= 0"])
  end
end
Something went wrong with that request. Please try again.