Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Quickfix: Restrict tinyrpc to version 0.9.4 #3

Closed
wants to merge 1 commit into from

Conversation

@freundTech
Copy link

freundTech commented Nov 27, 2019

tinyrpc 1.0.0 breaks python 2.7 support and only supports python3. 0.9.4
is the last version with python 2.7 support. Idealy this should be fixed
in the dependency list of ryu, but until that happens the problem can be
worked around by manually installing version 0.9.4.

Without this fix newly created virtual machines won't be able to run the
sdn controller

tinyrpc 1.0.0 breaks python 2.7 support and only supports python3. 0.9.4
is the last version with python 2.7 support. Idealy this should be fixed
in the dependency list of ryu, but until that happens the problem can be
worked around by manually installing version 0.9.4.

Without this fix newly created virtual machines won't be able to run the
sdn controller
@freundTech

This comment has been minimized.

Copy link
Author

freundTech commented Nov 27, 2019

I also opened a pull request with ryu here: osrg/ryu#84

@freundTech

This comment has been minimized.

Copy link
Author

freundTech commented Dec 2, 2019

This has now been fixed in ryu and is therefor no longer needed here.

@freundTech freundTech closed this Dec 2, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.