Document requirement for Python 2.7 for populate-project.sh #2

Closed
ghost opened this Issue Mar 13, 2012 · 1 comment

Comments

Projects
None yet
1 participant
@ghost

ghost commented Mar 13, 2012

After running populate-project.sh, which uses the stock system Python to pre-compile the .py files, requires Python 2.7 or on running the app gives the following error on earlier versions of Python (such as 2.6 on Snow Leopard):

RuntimeError: Bad magic number in .pyc file

It's easily solved by upgrading the stock version to 2.7 but the build-python.sh script could be configured to detect and use the same major version as the stock inbuilt version, e.g. using python --version.

Enforcing a minimum requirement for a modern Python isn't such a bad thing either though.

Owner

tito commented Jul 18, 2012

Thanks for reporting, i changed to use specifically the hostpython compiled within kivy-ios now.

tito closed this in b70106c Jul 18, 2012

Kamek referenced this issue Oct 28, 2012

Closed

ios.c errors #22

@gfyoung gfyoung pushed a commit to gfyoung/kivy-ios that referenced this issue Mar 22, 2017

@hayd hayd Merge pull request #2 from hayd/travis
Travis working
680922c

@gfyoung gfyoung pushed a commit to gfyoung/kivy-ios that referenced this issue Mar 22, 2017

@splanquart splanquart Merge pull request #2 from tito/fixes_and_kivy
Fixes and kivy
87b8770
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment