Build fails in Ubuntu 12.10 64 bit #814

Closed
eavc opened this Issue Nov 21, 2012 · 3 comments

Projects

None yet

4 participants

eavc commented Nov 21, 2012

Hi,

I have attempted to compile Kivy on a fresh install of Ubuntu 12.10 64 bit using easy_install as per the documentation. Unfortunately the build fails with multiple gcc incompatible type errors.

You may find the compiler output here:

git://gist.github.com/4128436.git

Any help will be appreciated.

Owner
tito commented Nov 21, 2012

It's a Cython bug. We already merged a fix for it, but it would be better if Cython fix it :/
In the meantime, use the Kivy master from github, or use Cython 0.17.1 (not 0.17.2).

Thanks!

@tito tito closed this Nov 21, 2012
Owner

eavc: Feel free to use the packages built in our PPA ;)

See: https://launchpad.net/~kivy-team/+archive/kivy and for nightlies https://launchpad.net/~kivy-team/+archive/kivy-daily

Contributor

As a reference for anyone who found this page because easy_install failed on Ubuntu:
sudo easy_install kivy
...some work is done, then a Cython error...

Here's the solution that worked for me (on Ubuntu 12.04 AMD64):

sudo add-apt-repository ppa:kivy-team/kivy
sudo apt-get update
sudo apt-get install python-kivy

Enjoy!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment