New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

GraphQL: please stop using "databaseID" #1404

Closed
mrtnzlml opened this Issue Jan 7, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@mrtnzlml
Copy link
Member

mrtnzlml commented Jan 7, 2019

Or any other deprecated field. See: https://github.com/kiwicom/mobile/search?q=%22databaseId%22&unscoped_q=%22databaseId%22

You can use id(opaque: false) if you really need it. Please let me know if something is difficult to do. One little trick could help you significantly - write queries like this:

{
  faq {
    databaseId: id(opaque: false)
  }
}

You can refactor later but the important thing is you stop using deprecated fields and therefore we can move forward in graphql.kiwi.com. Thanks!

@tbergq

This comment has been minimized.

Copy link
Collaborator

tbergq commented Jan 7, 2019

These are all used in MMB, I consider MMB in RN to be dead. Please feel free to remove those fields from graphql.

If MMB-RN is ever revived, I expect there will be a lot to fix.

@tbergq tbergq closed this Jan 7, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment