Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Inactive builds are shown for test run #245

Closed
okainov opened this Issue Mar 6, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@okainov
Copy link
Contributor

okainov commented Mar 6, 2018

Description of problem

Even if the build is set as "inactive" in the DB, it's still visible in the list

Component (web, API, etc)

web

Version or commit hash (if applicable)

4.1.0 or couple of commits ahead

How often reproducible

Always

Steps to Reproduce

  1. Create couple of builds
  2. Make on of them inactive
  3. Try to create test run
  4. Make sure even non-active builds are visible

Additional info

Looks like root cause is somewhere around line 385 in tcms_actions.js, if you comment var build_field = jQ('#id_build')[0]; then only actual active builds will be shown,

atodorov added a commit that referenced this issue Mar 7, 2018

Always select active builds for TestRun. Fixes #245
also remove the last parameter `active` from
bind_build_selector_to_product() because this function is never
called with more than 3 parameters!

@atodorov atodorov closed this in 1f9adfa Mar 7, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.