New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Tester field changes "None" in test run details view #459

Closed
chenchangjiang opened this Issue Aug 2, 2018 · 3 comments

Comments

Projects
None yet
2 participants
@chenchangjiang

chenchangjiang commented Aug 2, 2018

WARNING: do not publically report security issues in the bug tracker!
Ping us via email to coordinate the fix and disclosure of the problem!

Description of problem

Tester field changes "None" in test run details view

Component (web, API, etc)

web

Version or commit hash (if applicable)

5.1

How often reproducible

always

Steps to Reproduce

  1. create a test run and add a test case
  2. change case status to some status, e.g pass or fail, then tester filed will display the tester name
  3. click "Set to finished" or go to other page and then back to test run details page

Actual results

Tester field changes "None" in test run details view

Expected results

Tester filed should display test name

Additional info

No.

@atodorov

This comment has been minimized.

Show comment
Hide comment
@atodorov

atodorov Aug 2, 2018

Member

Can you post a screenshot

Member

atodorov commented Aug 2, 2018

Can you post a screenshot

@chenchangjiang

This comment has been minimized.

Show comment
Hide comment
@chenchangjiang

chenchangjiang Aug 3, 2018

11
22

I attach two pictures. If did have this issue, please help to fix this. This filed is useful for leader or manager to find who mark this case result. Thx.

chenchangjiang commented Aug 3, 2018

11
22

I attach two pictures. If did have this issue, please help to fix this. This filed is useful for leader or manager to find who mark this case result. Thx.

@atodorov

This comment has been minimized.

Show comment
Hide comment
@atodorov

atodorov Aug 6, 2018

Member

The problem is not in setting the status to Running or Finished. It appears that the Tester field is updated in the UI but probably not saved properly on the backend. Once the page is reloaded the previous value is shown.

Member

atodorov commented Aug 6, 2018

The problem is not in setting the status to Running or Finished. It appears that the Tester field is updated in the UI but probably not saved properly on the backend. Once the page is reloaded the previous value is shown.

atodorov added a commit that referenced this issue Sep 2, 2018

@atodorov atodorov closed this in c2b88fb Sep 3, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment