New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Default tester can't be assigned via TP #85

Closed
atodorov opened this Issue Oct 28, 2017 · 1 comment

Comments

Projects
None yet
1 participant
@atodorov
Member

atodorov commented Oct 28, 2017

Component (web, API, etc)

web

Version or commit hash (if applicable)

DEMO

How often reproducible

Always

Steps to Reproduce

  1. Create a Test Plan
  2. Add some Test Cases to it.
  3. Click the Cases tab
  4. Select Test Cases
  5. Click the Default Tester button
  6. Enter a valid tester email and click Update

Actual results

Nothing happens in UI, the POST ajax request fails with a 500 ISE.

Expected results

Default tester is updated.

Additional info

@atodorov atodorov added the bug label Oct 28, 2017

@atodorov

This comment has been minimized.

Show comment
Hide comment
@atodorov

atodorov Nov 7, 2017

Member

Note: appears to be happening either when an invalid username/email is entered -> raises ObjectNotFound exception which causes the view to fail

NOTE2: the UI widget claims both username and email are supported as inputs but the code only searches via username.

Member

atodorov commented Nov 7, 2017

Note: appears to be happening either when an invalid username/email is entered -> raises ObjectNotFound exception which causes the view to fail

NOTE2: the UI widget claims both username and email are supported as inputs but the code only searches via username.

atodorov added a commit that referenced this issue Nov 7, 2017

@atodorov atodorov closed this in 2f5ae4e Nov 7, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment