Permalink
Browse files

replace NEXT with MRO::Compat

Fixes warning for deprecation of NEXT

[ticket: https://rt.cpan.org/Public/Bug/Display.html?id=64056]
  • Loading branch information...
1 parent 695faf1 commit 90551b73d39880f5a092cbe2f68b1da66f443104 @kixx committed Jul 16, 2011
Showing with 2 additions and 2 deletions.
  1. +2 −2 lib/Catalyst/JobQueue/Job.pm
@@ -10,7 +10,7 @@ __PACKAGE__->mk_accessors(
);
use Carp;
-use NEXT;
+use MRO::Compat;
use Scalar::Util qw/refaddr/;
use version; our $VERSION = qv('0.0.1');
@@ -20,7 +20,7 @@ sub DEBUG { $ENV{CATALYST_DEBUG} || 0; }
sub new {
my ($self, @args) = @_;
- $self = $self->NEXT::new( @args );
+ $self = $self->maybe::next::method( @args );
$self->ID( refaddr($self) );
$self->flags( {} ) unless $self->flags;
return $self;

0 comments on commit 90551b7

Please sign in to comment.