New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

remove strict/warnings pragmas where Moo is used #12

Merged
merged 1 commit into from Jan 10, 2017

Conversation

Projects
None yet
2 participants
@kwakwaversal
Contributor

kwakwaversal commented Jan 10, 2017

Moo's current minimum requirement (1.006000) and above imports the strict and warnings pragmas into calling packages. Explicit use seems redundant.

This is part of the CPAN pull request challenge. I would like to take a look at the issue explicitly flagged for the cpan-prc when I get some more time.

remove strict/warnings pragmas where Moo is used
Moo's current minimum requirement (1.006000) and above imports the strict and
warnings pragmas into calling packages. Explicit use seems redundant.

@kjetilk kjetilk merged commit 8fdf083 into kjetilk:master Jan 10, 2017

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
@kjetilk

This comment has been minimized.

Show comment
Hide comment
@kjetilk

kjetilk Jan 10, 2017

Owner

Great, thanks! I have been putting in strict and warnings as a matter of habit :-)

It is really nice if you had a look at Issue #1 ! It is the thing standing between it and a 1.0 release. :-) I hang out in various IRC channels, including #moose if you need me.

Owner

kjetilk commented Jan 10, 2017

Great, thanks! I have been putting in strict and warnings as a matter of habit :-)

It is really nice if you had a look at Issue #1 ! It is the thing standing between it and a 1.0 release. :-) I hang out in various IRC channels, including #moose if you need me.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment