Skip to content

kkaefer/DEPRECATED-node-zlib

master
Switch branches/tags
Code

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
lib
Mar 11, 2011
Apr 20, 2011
Mar 11, 2011
Mar 11, 2011
Mar 11, 2011
Mar 11, 2011

DO NOT USE – DEPRECATED

This extension is deprecated since the functionality was folded into node.js core: https://nodejs.org/dist/latest/docs/api/zlib.html

NAME

node-zlib - Simple, synchronous deflate/inflate for node.js buffers.

USAGE

Install with npm install zlib.

var Buffer = require('buffer').Buffer;
var zlib = require('zlib');

var input = new Buffer('lorem ipsum dolor sit amet');
var compressed = zlib.deflate(input);
var output = zlib.inflate(compressed);

Note that node-zlib is only intended for small (< 128 KB) data that you already have buffered. It is not meant for input/output streams.

BUILDING

Make sure you have zlib installed. Mac OS X ships with it by default.

To obtain and build the bindings:

git clone git://github.com/kkaefer/node-zlib.git
cd node-zlib
./configure
make

You can also use npm to download and install them:

npm install zlib

TESTS

expresso is required to run unit tests.

npm install expresso
make test

CONTRIBUTORS

LICENSE

node-zlib is BSD licensed.

About

DEPRECATED – Simple, synchronous deflate/inflate for node.js buffers

Resources

License

Stars

Watchers

Forks

Packages

No packages published